handdator

Visa fullständig version : Multiwii problem. Kan ej starta motor.



Fredda
2012-12-03, 16:22
Håller som bäst på att installera ett Multiwii pro på min tricopter.

Men jag får ej igång motorerna, statuslampan på kortet tänds aldrig när jag drar sidoroder åt höger (inte åt vänster heller för den delen).
Esc är kalibrerade, har testat ändra "minthrottle" till olika värden´, ändrat på trv adj i sändaren.


jag har även installerat multiwii GUI, där skulle man visst kunna se hur utslagen på kanalerna ser ut.
Men när jag kollar "rc live data" så står alla kontroller i mitten, oavsett vad jag gör med sändaren. Men sändare och mottagare har kontakt.

Vad är problemet?

Fredda
2012-12-03, 16:29
På denna bild syns vad jag menar med "rc live data"

http://i1237.photobucket.com/albums/ff467/frj79/IMG_2308.jpg

Fredda
2012-12-03, 21:15
Ja nu börjar det kännas hopplöst.

Kontrollkortet verkar fungera fint när man testar i GUI, sändare och mottagare binder, men någon signal mellan mottagare och kontrollkort verkar inte finnas.
Har testat 2 olika mottagare med samma resultat, Orginalmottagare AR6200 och Orangerx 610.
Båda vägrar armera kortet eller ge utslag i GUI.

Suck.

PatrikE
2012-12-03, 21:47
Lite motfrågor...
Vad har du för version laddad i kortet? Windows gui't stöder V2.1.
Fungerar övrig "Live datan" Gyro Acc mm?
Anslutit till rätt Comport?
Har du gjort rätt inställningar i Config filen?

Basic setup

#define TRI
#define CRIUS_SE
Det ska ge en fungerande setup att starta med.

simonarvestrand
2012-12-03, 21:48
har du testat typ ett servo direkt på mottagaren ?

Fredda
2012-12-04, 06:01
Jag har v2.1 laddad.Övrig livedata fungerar.Rätt comport.#define crius_se, har jag ej angett. Bara #define tri. Ska fixa efter jobbet får vi se.Har som sagt bara angett d koder jag hittat info om att jag ska ange.Servo på mottagaren rör sig, men inte om jag flyttar till kortet.

UndCon
2012-12-04, 08:27
Är det ett Crius kort skall du ange det (eller annan typ av kort) - sedan skall du kunna se de gröna staplarna röra sig när du drar i spakar på radion

Gör de inte det har du ingen kommunikation mellan mottagare -> MultiWii
(Troligen bara config fel)


//UndCon

Fredda
2012-12-04, 10:00
Är det ett Crius kort skall du ange det (eller annan typ av kort) - sedan skall du kunna se de gröna staplarna röra sig när du drar i spakar på radion

Gör de inte det har du ingen kommunikation mellan mottagare -> MultiWii
(Troligen bara config fel)


//UndCon


Aha, det var kortet jag angavs där, ja isf har jag angett det, men detta heter #define FFIMUv2.

Bara fortsätta leta configfel då. Nåt har jag ju bevisligen missat.

har gjort allt enl denna instruktion http://www.hobbyking.com/hobbyking/store/uploads/201872452X19082X23.pdf

Fredda
2012-12-04, 10:02
och denna http://www.hobbyking.com/hobbyking/store/uploads/201779733X365809X32.pdf

UndCon
2012-12-04, 11:01
OK - ett sådant kort...då är det exakt så du ska göra - som dom beskriver, ändrar du något annat är det bättre att börja om.

Jag använder inte samma GUI som du...
får du upp anslutningen i MultiWii GUI ?

Fredda
2012-12-04, 12:39
Finns det flera olika gui alltså.
Om du menar anslutningen mellan kortet o datorn så fungerar den.

En annan intressant detalj som jag glömt, är att sidoroderservot kompenserar för röresler på kortet när det är igång. men det kanske inte har nåt med kommunikation mellan mottagare o kontrollkort att göra.

Fredda
2012-12-04, 17:17
Problemet löst.
Ibland är är man så blind så det är skrämmande.

metric
2012-12-04, 18:43
Nu får du berätta hur du löste det!

uffe40
2012-12-04, 18:48
Trottel åt höger eller var det vänster för att armera

Fredda
2012-12-04, 21:03
Det är så dumt så jag skäms för att tala om det.
Hade vänt kablarna mellan mottagare o kort åt fel håll. Konstigt nog fanns det tillräckligt med ström i signalen för att få dioden i mottagaren att lysa, o därmed lura mig att den bundit med sändaren.

När väl det var åtgärdat så hoppa allt igång utan bekymmer. Så nu kan man börja leka med multiwii på riktigt :)
Nu ser det ut som det ska snöa en vecka framöver, så lär väl ta ett tag innan man kommer ut o testar, o börjar leka lite med gps-funktionerna.

Kommer hålla min tricoptertråd uppdaterad.

Fredda
2012-12-04, 21:12
Trottel åt höger eller var det vänster för att armera

Vänster i detta fall.
När jag äntligen kommit på felet,,,:banghead: