handdator

Visa fullständig version : Stora problem Alexmos brushless styrning



Stiffe
2013-06-02, 15:54
Hej

Efter att köpt en väldigt gedigen gimbal av fredrik här på forumet så har jag nu i några veckors tid försökt få detta enligt alla fantastiska filmer mm på nätet systemet att funka utan resultat , jag har normalt inga problem att setupa diverse datorprylar , multicopter FC ( iaf DJI ) men gått bet på denna , har läst alla manualer kollat på setupfilmer mm. där allt bara funkar direkt , jag har försökt utesluta alla felkällor och köpt 2 styrkort på olika ställen , 2 omg motorer på olika ställen , provat olika PID inställningar mm. Är det jag som är helt korkad eller ??

Den styr inget och den bara skakar och hittar inget stabilt läge och jag fattar inte varför

Provat följande

Olika firmware från 1.2 - 2.0
Olika styrkort CSG och Mikrokopter ( flyduino )
Olika motorer I flight GBM 2006 samt GBM 2008
kalibrerat sensor 6 way och i Gui ser det Ok ut
diverse PID inställningar
balanserat gimbalen bra
polvänt motorer

Hjälp !

Tacksam för all input gjorde en liten film hur det beter sig


https://vimeo.com/67498999

zooks
2013-06-02, 19:00
Nu vet jag inte exakt hur alexmos kort fungerar, men jag tror nog att det är pid-inställningarna.
Kan skapa samma fenomen på min genom att använda fel inställningar.
Koppla bort ena motorn och jobba bara med den andra tills den är stabil.
Sätt I på 0 och testa med P på 20 och D på 2, sen är det bara att jobba sig framåt med D tills den står still.

Tokaz
2013-06-02, 22:14
Pröva sätt sensorn på kameran ist. Min funkar inte alls om jag har den på samma ställe du har den. Sen har jag monterat sensorn så att kabeln går in på vänster sida sett bakifrån. Kanske är fel men den funkar iaf :)

simonarvestrand
2013-06-03, 06:27
Kolla pidinställningarna, om du gör som det beskrevs ovan och har en för hög d så kan du lätt få sådana problem.

Börja med endast P och Ställ in så den reglerar utan att svänga massor, den kommer förmodligen inte bli helt rak, det är här. I hjälper till, labba lite med p och i tills det blir bra, d är mycket känslig och svår att använda men gör allt bättre men trimma in den sist och i små små steg.

Sent from my HTC One X using Tapatalk 2

Stiffe
2013-06-03, 12:05
Tackar för tipsen !

Jag har provat det mesta men kommer ingen vart tyvärr, blir varken bättre eller sämre hur jag ändrar , snackade med fredrik igår och fick några tips men utan resultat , skickar nu upp det till Fredrik så får han kika på det

Stiffe
2013-06-04, 22:35
Nu har Fredrik löst problemen , Stort Tack MR alexmosgimbal expert :) och glad och tacksam är jag , nu ska det flygas och filmas på en rätt stor Jeepträff i Småland i helgen

simonarvestrand
2013-06-04, 22:39
vad va problemet?

Stiffe
2013-06-04, 23:09
vad va problemet?

Han bytte några kontakter och fick till PID inställningarna samt balanserade om lite på kameran , bara att inse att det inte är min grej med PID inställningar :banghead: , annars brukar jag inte gå bet på tekniska prylar i första taget

cyberpete
2013-06-12, 11:35
Fått hem mina motorer idag och bara provat snabbt med alexmos kortet. Motorerna snurrar konstant och börjar undra vart jag ska börja justera ?

Ska printa ut gimbal i veckan för ett riktigt test sedan :)

cyberpete
2013-06-13, 17:21
Någon som har någon input i frågan ? :)

Fredrik R
2013-06-13, 18:58
Har du kopplat in kortet till datorn och kalibrerat gyrot?


Sent from my iPhone 5 using Tapatalk 2

magnusvr
2013-06-15, 09:30
Fått hem mina motorer idag och bara provat snabbt med alexmos kortet. Motorerna snurrar konstant och börjar undra vart jag ska börja justera ?

Ska printa ut gimbal i veckan för ett riktigt test sedan :)

Så gjorde mina också, tills jag bytte sladdarna mot varandra. :) Hade kopplat Roll/pitch på fel kontakt, så hur de än försökte hitta hem, blev det bara värre och det snurrade runt runt tills allt var en boll av sladdar.

En annan upptäckt du kanske gör är balanseringen, hur viktigt det är att kameran sitter i och att gimbal+kamera är balanserat, dvs det ska justeras i djup och bredd tills det i princip inte tippar åt något håll, när riggen är avstängd.

/Magnus

sm0sbi
2013-06-16, 20:19
Vad blev der för PID inställningar till slut när Fredrik hade fixat med den?

Fredrik R
2013-06-16, 20:24
http://img.tapatalk.com/d/13/06/17/6eqareva.jpg



Sent from my iPhone 5 using Tapatalk 2

sm0sbi
2013-06-16, 20:32
jag får bara nästan till det, roll är ok men pitch skakar en del. vart satte du sensorn??

power 150, det är mycket, får prova så högt..

Fredrik R
2013-06-16, 20:42
Satte sensorn på kameran.


Sent from my iPhone 5 using Tapatalk 2

cyberpete
2013-06-16, 21:30
Tips på kablage att använda till sensorn ?

Fredrik R
2013-06-16, 21:43
Böjligast möjliga.


Sent from my iPhone 5 using Tapatalk 2

sm0sbi
2013-06-17, 07:14
Såhär långt har jag kommit nu, ser bra ut så länge det inte blåser eller att jag flyger, stannar jag och hovrar kommer skakningarna. Det blåser ca 6 m/S i medelvind och krantoppen är på ca 80m höjd, då det blåser säkert rätt bra där uppe :)

http://youtu.be/KtS1oH_j_rA

Kanske dax att ge sig på gain i NAZAn för att få ordning på detta....

någon som har någon ide?

cyberpete
2013-06-18, 06:33
Min ser ut så här. Det är första prototypen men är nöjd. Nästa blir med kolfiber och printade delar. :-)


Skickat från min GT-I9300 via Tapatalk 2

simonarvestrand
2013-06-18, 08:06
Min ser ut så här. Det är första prototypen men är nöjd. Nästa blir med kolfiber och printade delar. :-)


Skickat från min GT-I9300 via Tapatalk 2

Ser lätt och smidig ut

cyberpete
2013-06-18, 19:39
Kliar mig i huvudet.....

Har balanserat gimbalen och kalibrerat acc.. Allt ser bra ut i Gui. När jag kopplar in batteriet så tiltar den 45 grader på roll och jag ser att den även göra det i Gui.

Har samma problem på pitch men tar det sen.

Varför vill den tiltta?

Skickat från min GT-I9300 via Tapatalk 2

cyberpete
2013-06-20, 06:31
Någon?

Kanske har missat något enkelt....

Skickat från min GT-I9300 via Tapatalk 2

cyberpete
2013-07-14, 15:27
Slängt ihop en ny gimbal.



Skickat från min GT-I9300 via Tapatalk 2

bjerred
2013-07-15, 06:55
Cyberpete,
provfilmade du med den enkla prototypvarianten? Den ser ut att vara bra för DIY.

Lars

Stiffe
2013-08-17, 00:47
Hej satte ihop en liten gimbal för Gopron med I flight GBM 2212 motorer , nån som har en liknande setup och vill dela med sig av inställningar på Alexmos