handdator

Visa fullständig version : Ryckande servo



Bertone
2014-12-17, 23:11
Hej
Jag har en hexacopter med uppfällbara landningsställ, tiltbar kamera samt tiltbar fpv-kamera med servo som avtryckare. Många servon med andra ord. Alla drivs från en bec och signalkablarna går till RX. Varför rycker dom? Maskinen låter som ett flipperspel så fort man rör något servo. Några förslag?
Christian

Kenneth E
2014-12-17, 23:45
Kontroll mät spänningen när servona inte rycker och sedan när de rycker.

Bertone
2014-12-18, 00:09
Skall mäta imorgon.

jocke1963
2014-12-18, 01:30
Vad har du för radio?

Bertone
2014-12-18, 23:12
Jag har Taranis med X8R.
Nu har jag testat med bara ställen o fpv-kameraservot inkopplade. Varje gång jag manövrerar kameran så rycker motorerna, utan undantag och mkt "synkat". Spänningen till ställen sjunker ~0.1V när kameran rör sig. Känns som att det är signalen som "läcker".

Kenneth E
2014-12-19, 07:48
Händer samma sak utan kameran, är gimbalen balanserad? Gimbalen har väl två servon, gäller det båda?
Jag har haft servo som orsakat detta problemet, bara klippa kabeln och kasta annars riskerar man hela farkosten.
Prova ut vilket servo det är och byta ut det och gör samma test en gång till.
Det kan vara en annan sak också och det är om servona drivs via bec tillsammans med mottagaren, blir bec överbelastad så kan den inte leverera sin lovade uteffekt och det blir spänningsdrop som man oftast endast kan se via oscilloskop, men det gör att elektroniken inte fungerar som den bör oftast som du beskriver att alla servona rör sig okontrollerat.

Bertone
2014-12-19, 14:24
Ja, just nu testar jag med endast ställen samt servot som tiltar fpv-kameran. Jag skall byta kameraservot och göra samma test igen. Gimbalen är fn. inte ansluten. Kan också prova med bara ett ställ inkopplat. Tur att det inte är flygväder!
Hade dock VÄLDIG gärna testat min nya gimbal (Rctimer ASP 2-ax) och min nya Sony a5100!

Kenneth E
2014-12-19, 15:57
Vi kunde kanske testa tillsammans en dag. Jag behöver flyga av mig, bara säg till.

Bertone
2014-12-19, 17:17
Absolut, Kenneth! O jag hade gärna tittat på din stora quad. Vi är inte bortskämda med flygväder precis.
Nu har jag kommit fram till att det troligen är ett av ställen som bråkar. Har försökt ge det landningsstället 5V från separat batteri, men av någon anledning funkar inte det. Skall låna ett likadant ställ o se om det fungerar bättre.

Bertone
2014-12-20, 19:33
Problem solved! Tyvärr så förstår jag fortfarande varför dom ryckte....
Jag flyttad landningsställen från kanal 12 till kanal 11, och nu rycker dom inte. Skumt.
Fpv-tilt var på kanal 11.
Dags för en öl

Kenneth E
2014-12-20, 20:22
Du med dina problem och jag med mina. Jag får ingen bra bild ur min FPV modell, blir tokig.
Kul det löste sig för din del.
Sitter själv med en GT
Ken

Bertone
2014-12-21, 00:36
Alltid är det nått...
Under en knapp vecka för nån månad sen fungerade alla mina tre multicoptrar perfekt. Det var tider de