handdator

Visa fullständig version : 250 Quad, problem.



Antholn
2015-09-13, 15:10
Hej! Har byggt ihop och programmerat en 250 FPV quad. Men när jag testar att köra med den så flippar den runt så fort den lämnar backen. Den kan alltså inte hovra.
Har kollat så motorerna snurrar åt rätt håll. Styrningen verkar dock funka, när jag kör motorerna på lågvarv och testar att köra framåt, sidan, bakåt så ökar rätt motorer fart.

Någon som har en ide på vad som kan vara fel? Snart ger jag upp...

Copterdude
2015-09-13, 15:34
Vet inte vad du har för styrkort men kolla så den sitter åt rätt håll och att motorerna är kopplade till rätt uttag. Rätt sorts proppar medurs/moturs på rätt motor. Är något av detta fel flippar den. Annars kanske det kan vara PIDsen som är helt fel.

Antholn
2015-09-13, 16:00
Styrkortet är ett CC3D, visste inte att den skulle sitta åt ett visst håll, men det borde inte ha någon påverkan vid hovring. Däremot är jag osäker på om jag kopplat rätt mellan mottagaren och styrkortet. Kan bifoga en bild.
54508

Copterdude
2015-09-13, 16:08
Är en pil på kortet vilket som är framåt men man kan ändra i mjukvaran om man vill ha den åt ett visst håll.
Tror inte det ska spela nån roll hur man kopplad kablarna då man ställer in kontrollerna i mjukvaran.
Det kan jue vara så att nån kanal är inverterad eller liknande. Har du kört igenom GCS för att ställa in allt ?
Tyvärr använder jag ej Openpilot så får låta nån som kan den biten bättre svara annars.

Antholn
2015-09-13, 16:37
WOW! Testade att sätta styrkortet med pilen framåt som du sa, och det var det som var problemet! Trodde det skulle vara något större fel.Tackar, du gjorde min dag!

Copterdude
2015-09-13, 16:46
WOW! Testade att sätta styrkortet med pilen framåt som du sa, och det var det som var problemet! Trodde det skulle vara något större fel.Tackar, du gjorde min dag!

Inga problem, Kul att det funka ! :)