handdator

Visa fullständig version : Behöver hjälp med Naza lite och Taranis



Jorgen
2015-09-13, 23:06
Hej,

Jag hjälper en vän att konfigurera hans Discovery med Naza lite, radion är en Taranis med X8R mottagare som är kopplad till Nazan via SBUS.

Jag får funktion på det och allt är kalibrerat men Control mode switch kanalen blinkar till från det inställda läget till failsafe ganska frekvent. Det kan gå mellan en och tio sekunder mellan varje gång den gör det. Den ställer sig då i samma läge som när jag slår av sändaren. Det spelar ingen roll om switchen står i manuellt, atti eller GPS.atti.

Är det här något någon känner igen eller har några ideer om hur jag skall fixa.

Jörgen

Jorgen
2015-09-14, 20:21
Jag hittade inlägg från 2013 som beskriver problemet jag ser.

Frsky släppte en buggfix för ett stack overflow problem i S.Bus koden i slutet av Januari i år. Både EU och Non-EU mottagarna är drabbade och tycks ha varit det från dag ett. Det återstår att se om det löser problemet jag ser. Det är dags att leta fram lite kontakter så att jag kan löda en uppdateringskabel.

Jorgen
2015-09-14, 22:47
Det hjälpte tyvärr inte, den fladdrar tyvärr över i failsafe i någon tiondels sekund lite då och då. Jag får prova att skapa en ny modell och binda om. Om det fladdrar efter det så får det bli att prova med en S.Bus mottagare av annat fabrikat för att se om problemet ligger i Nazan.

Uppdateringen gick i alla fall utmärkt med en vanlig RS-232 port, dvs en vanlig serieport. Det låter lite konstigt då RS-232 använder både positiv och negativ spänning men FrSky dokumentatioen säger att det är RS232 signalnivåer som gäller. Det stämmer också bra med att FrSky signalen tydligen är inverterad jämfört med normal TTL, precis som RS-232.

DB9-2 går till signal på Smartport
DB9-3 går via en diod till signal på SmartPort
DB9-5 går till jord på SmartPort

Jorgen
2015-09-15, 00:18
Det fungerar utmärkt när jag använder en OrangeRX mottagare med s.bus utgång kopplad till min DX18. Jag hade den under bevakning en lång stund utan att se något.

När FrSky prylarna glitchade så slog U kanalen ner till failsafe med ett värde på +491, när jag stängde av Taranis radion så hamnade U kanalen på +491. När jag satt och höll spakarna i ändlägen under tiden som U kanalen glitchade så såg jag inget hända med de andra kanalerna.

När jag stänger av DX18 radion så hamnar U kanalen på 491 precis som med avstängd Taranis.

Jag hittade ytterligare en updatering till X8r, den första s.bus fixen skedde den 22a januari och den här uppdateringen kom den andra Juli. Den nämnde också s.bus förbättringar men tyvärr så är felet kvar även efter att jag uppdaterat till den versionen.

Nästa gång jag orkar felsöka så får jag titta på olika alternativ för failsafe på FrSky. Det är kanske något sånt som trasslar.