handdator

Visa fullständig version : Naze32 rev6 seriell kommunikation död



psafth
2016-01-25, 11:32
Hej,

Jag har en quad med en naze32 rev6 och skulle i helgen justera lite PID's.

Kopplade upp min naze till datorn via USB och tryckte på "Connect" i CleanFlight. Cleanflight kopplade upp och jag gjorde ett par justeringar samtidigt som jag fick en fundering och tänkte att jag skulle kolla vad andra ställt in för att få lite mer "snappy" kontroller. Startade därför min webbläsare och googlade lite.

Mitt under mitt googlande så plingar det till i datorn och meddelandet "USB-kontrollen känns inte igen" dök upp. Jag tog då upp CleanFlight och såg att jag inte längre var uppkopplad mot min naze. Jag försökte koppla upp igen men utan lycka. Får felmeddelandet "No configuration received within 10 seconds. Communication failed."

Jag tänkte att det var min dator och USB-portarna som spökade. Så jag gick till en annan dator och hämtade hem drivrutiner och CleanFlight. Samma sak där. Enheten finns (SiLabs USB to uART) och fungerar men jag får samma felmeddelande.

Jag testade att flyga och min quad flyger som vanligt men jag kan helt enkelt inte längre koppla upp och konfigurera.

Jag testade att brygga boot-padsen och flashade om min naze. Att flasha gick bra men jag kan fortfarande inte koppla upp.

Är det så att det seriella interface som finns på min naze har dött? Någon annan som haft samma / liknande problem?

Jag kan tillägga att min dator tidigare dödat en USB2UART sticka (fr. Hobbyking) med samma felmeddelande "USB-enheten känns inte igen" helt plötsligt från ingenstans. Kanske har ett moderkort eller bios som matar ström på helt fel ställen...

Jag är tacksam för all typ av input.

/ F

andWho
2016-01-25, 11:46
Om du kan flasha via USB porten så är den ju inte död. Du har nog bara tappat inställningen MSP på UART1 på ports-sidan.
Prova att flasha om igen med "Full chip erase" så får du tillbaks alla default inställningar, inkl MSP.
/A

psafth
2016-01-25, 11:48
Tack för snabbt svar. Jag flashade om med "Full chip erase" men samma problem kvarstår.

andWho
2016-01-25, 12:34
Mysko.
Jag har motsatta problemet på en dator, en laptop. Kan inte flasha, kan funka ibland med boot-paddarna. Att ansluta o konfigurera med CFcfg är inga problem.
Med en annan stationär dator har det hittills (knock-knock) inte varit några problem alls.
Båda datorerna uppdaterade med senaste Win10 etc .
Mörker...

Så här års är det ju väldigt torrt i luften och man märker att det kan bli statiska urladdningar mot allt man tar i. Sådant kan skada FC och annan öppen oskyddad elektronik. Hantera grejorna försiktigt, med jordat handledsband, när ni meckar.
/A