handdator

Visa fullständig version : Miniquadmotorer som krånglar



The_Flying_Ginger
2016-05-03, 13:08
Min quad (en BeeRotor210) flög helt okej tills jag bytte motorer. Jag bytte från "Rctimer FPV racing edition FR2304/2100kv" p.g.a. dåliga lager, till "Rctimer FR2205-2300KV Red High Power Motor". Med dem nya motorerna så flyger den som om yaw P skulle vara alldeles för högt. Men det verkar inte ha någonting att göra med pids.
Jag har provat 3 olika set med proppar och provat att ändra yaw pids. Men absolut ingen skillnad. Så jag rev quadden och provade varje motor med en servoprovare.

Så här gör alla 4 motorerna:
https://youtu.be/LvFVGmchcho

Någon som haft samma problem?

Min setup är:
BeeRotor210
Rctimer FR2205-2300KV High Power Motor
DYS XM20A ESC
Frsky X4RSB
Zippy 1800mAh 40c 4s/turnigy 30-40c 2200mAh 3s
Frsky taranis x9d plus
Turnigy action cam/sj4000
700tvl ccd fpv cam
Micro minimosd with kv team mod
TS5828 600mw fpv tx
HQ 5030 props
Naze32 rev6 running betaflight and sbus

//Martin

Glattnos
2016-05-03, 14:14
Har du kallibrerat ESC:erna?

JohnNordstrand
2016-05-03, 14:59
Tror också att problemet kan sitta i kontakten mellan motorer och esc. Har du grejer för att uppdatera firmware i dem? Om du har det och kör med BLheli skulle du kunna testa att ändra motor timing till medium eller low. Annars skulle det nog kunna lösa sig om du bara uppdaterar dem

The_Flying_Ginger
2016-05-03, 15:01
Ja, innan jag bytte motorer. Inte ska man väl behöva göra det igen?
Och om jag använder "motor test" i cleanflight config så snurrar bara motorerna om jag konstant rör slidern. Om man släpper den med musen så stannar motorerna efter någon sekund

The_Flying_Ginger
2016-05-03, 15:04
Aha! Vad heter verktyget som jag kan uppdatera esc med? Jag kör med stock BLheli och både oneshot och dampened light är aktiverat default så har inte ändrat något i firmwaren

JohnNordstrand
2016-05-03, 21:27
Du kör med ett program som heter BLHeliSuite för att ändra inställningarna. Det finns lite olika adaptrar till olika esc:er för att koppla dem till dator. Denna borde fungera till dina esc:
http://www.hobbyking.com/hobbyking/store/__86538__DYS_ESC_USB_Linker_ESC_Programmer.html

Annars en sån här, den funkar till typ allt:
http://www.kjell.com/se/sortiment/el-verktyg/elektronik/arduino/moduler/arduino-seriell-adapter-for-usb-p87872

The_Flying_Ginger
2016-05-04, 07:27
Tackar! Ska lägga ned lite energi på detta :)

Hoppsan_84
2016-05-04, 11:32
Eftersom du kör Betaflight kan det gå programmera escarna direkt med FCn. Beroende på vilken version av Betaflight du använder kan du behöva köra BLheli Beta

MarkusH
2016-05-04, 11:57
Inte säker på att det fungera att programmera esc med Naze32 rev 6. Om jag fatta rätt så är det något strul med detta på en del rev 6 kort.

Hoppsan_84
2016-05-04, 17:03
Ok. Inte på mina tre så det är värt ett försök.

MarkusH
2016-05-04, 18:02
Köpte mitt naze32 på banggood för några veckor sedan. Men tydligen finns det olika versioner. Hittade detta.
The difference between these revisions are:

6 has no diode, so the ESCs ended up being powered from the USB 5v line, and pass-through ESC programming doesn't work
6a has issues with the spektrum port
6b fixed the issue with the spektrum port

But every revision works well as an FC, and passthrough works fine in the later 2 revisions.

The_Flying_Ginger
2016-05-12, 15:30
Tack för alla svar!
Det fanns blheli bootloader i fartreglagen så jag uppdaterade alla till senaste blheli genom naze32. Ingen skilland. Provade att ändra motor timing till low, men ingen skillnad då heller. Om man sänker P till nästan ingenting på yaw så blir det bättre men absolut inte bra.
Den driftar också till höger på yaw.

Så är flyger den:
https://youtu.be/0u1PBRUKaFs
Det ser lite ut som om den skakar på roll men när man flyger känns det att det definitivt är yaw som är konstig.

tobbelerone
2016-05-12, 20:17
Jag har haft samma! Det är din Naze32 rev6.... byt till en f3 eller en rev5 så lovar jag att ditt problem är löst. Trodde det vara mina esc eller pids men sista jag bytter var min Naze32 rev6 till en rev5 så var problemet löst!

tobbelerone
2016-05-12, 20:18
Det är gyrot i rev6 som är helt kasst.. det är de som orsakar ditt problem

The_Flying_Ginger
2016-05-12, 21:10
Jag har en rev5 liggande så jag ska prova den! Tack för tips

tobbelerone
2016-05-13, 21:26
Funkade det?

The_Flying_Ginger
2016-05-16, 19:50
Ja! Tack för all hjälp, den verkar flyga nu och det var förmodligen min naze som var problemet.

The_Flying_Ginger
2016-05-21, 00:50
Det verkar nu mer som om det skulle kunnat vara ett problem med 5v strömförsörjningen. Den flög nästan bra efter jag bytt till en rev5 naze men vid en hård sväng eller punchout så twitchade den på yaw samtidigt som jag tappade fpv bilden helt. Så jag provade att driva min osd från en ubec istället för regulatorn som sitter inbyggd i ramen. Nu flyger den perfekt i 98% av fallen och även när den twitchar så har jag fortfarande bild. Kanske att en naze32 rev5 drar mindre ström än en rev6 och därför vart det bättre när jag bytte till den...?

Killenheladagen
2016-06-17, 05:59
Jag har bytt till Naze32rev5full från cc3d-coptercontrol och förutom övergången Librepilot-Cleanflight som var jobbig så i övrigt tyckte jag quaden flyger "bättre" med Nazekortet, speciellt när PIDsen blivit tunade, vet ej om Naze:n är snabbare i sina beräkningar eller vad det är som gör denna skillnad?
Vad är den mest prisvärda FC för miniquad som finns nu? har hört mycket bra om KISS fc?

(bryr mig inte riktigt om de "stora" funktionerna (som Naze32rev5Full har som jag förstår deT) i GPShantering, RTH, autoland, waypoints etc, jag behöver bara ACRO egentligen, råkar jag snubbla över en gpspuck installerar jag den nog bara för säkerhets skull, ev en osd då också)


TS; Skönt att hitta problemet? spec efter du demonterat allt och kört alla esc+motorer separat, jag vet hur jäkla jobbigt en sådan felsökning kan vara, kan verkligen suga tid och energi så länge problemet kvarstår, jag kan nästan bli besatt av att lösa sådana problem, kan sitta 5+h i rad och vara irriterad tills man tjuter av glädje till sist och springer ut för fälttest!
Hade ett sånt moment igår, dock ihållande regn så kan inte prova riktigt än, dock tror jag nu att jag till sist fått till en riktigt stabil och bra 5.8länk samt 2.4länk!!!
Man kan inte flyga quad fullt ut om man inte har en god signal, alla "trick" osv där quaden tillfälligt blir skymd eller rollar/flippar väldigt fort (och skymmer sin egen antenn) kan ge småstörningar med en OK signal men har man som jag haft, då kunde bilden försvinnna 1-2s helt, då är det inte alls kul, speciellt som saker händer väldigt fort med dessa små fartmonster. lycka till!
mvh Gustaf