handdator

Visa fullständig version : Nybörjare på FrSky Taranis



Pumpe
2019-05-09, 11:14
Hej. Nu börjar suget efter modellflyg komma tillbaka. Köpte mig en FrSky Taranis x9D (ej plus) när den var ny men det blev liksom inget gjort med den då för tiden räckte inte till och det är nått år sedan jag flög alls sist.

Var ska jag börja läsa om vilken firmware osv som gäller. Gör man fortfarande inställningarna i datorn och för över? Det verkar som att jag har gjort profilen för min funcub mer eller mindre färdig direkt i sändaren.

Alla mina mottagare är från tiden innan EU firmware så det kanske ställer till problem?
Några hårdvarufixar man bör göra? Märkte att den surrade lite i högtalaren nu när jag startade upp den, kommer inte ihåg att den gjorde det från början.

pernstig
2019-05-09, 12:51
OpenTx och OpenTx Companion nya versioner finns här:
http://www.open-tx.org/downloads

Manualer, firmware m.m. för FrSky:s produkter finns här:
https://www.frsky-rc.com/download/

Flera trådar i ämnet finns i detta forum, till exempel:
http://www.rcflyg.se/forum/showthread.php/55355-Open-Tx-det-flexibla-s%C3%A4ndaroperativet

Edit: Din X9D nonplus har då inte EU firmware och om du uppdaterar till nyare versioner väljer du en non EU-version så ska det funka med dina gamla mottagare.

thoabr
2019-05-09, 12:51
Hej

Om allt funkar med mottagare å sändare behöver du inte göra nåt. Programerar det mesta med sändaren.

Kommer inte ihåg riktigt men eu tror jag var lite sämre räckvidd.

Är du inte van vid dator hur man för över filer ock så. (kan ställa till det) Behåll det som det är är mitt råd.

Thomas

McRegor
2019-05-09, 17:15
Nja - nuvarande EU-programvara har nog inte nån sämre räckvidd - tror att det var nån tidig variant.
Det kan vara lite småtrixigt att uppdatera tidiga versioner av OpenTX till aktuell version men det brukar gå men man måste läsa på ordentligt och ha rätt drivers i PCn också vill jag minnas - men det är länge sen nu.
Lycka till !
Roger

FinnbyFraggel
2019-05-10, 06:43
Du vill absolut uppdatera din firmware till minst 2.1.9 eftersom tidigare versioner har en bugg som genererar jitter och drift på kanalerna.
/Jonas

Skickat från min Taranis via Tapatalk

Gasman
2019-05-11, 19:37
Kan vara idé att byta den interna knappcellen i sändaren. Min nonplus-sändare tappade datum och klockslag efter ca 3 år. Med ny knappcell funkade det igen.

Sedan är det lite pyssel att uppgradera från ver 1 till ver 2. Jag rotade fram en gammal tråd där jag beskrev tillvägagångsättet.
http://www.rcflyg.se/forum/showthread.php/36595-FrSKY-TARANIS?p=385506&viewfull=1#post385506

Pumpe
2019-05-19, 08:16
Ska läsa på lite. När det gäller EU vs Non EU firmware, eftersom jag redan har Non EU mottagare så måste jag fortsätta med det. Betyder det att jag måste köpa mottagare från utlandet?

McRegor
2019-05-19, 08:51
Pumpe - om du har D16-mottagare (X-serien och S-serien) så kan du uppdatera dessa (flasha om) till EU-LBT. Och likaså åt andra hållet - köper du EU-LBT-mottagare så kan du ändra dessa till International.
Roger

Pumpe
2020-04-11, 21:03
Ok. Testar igen ett år senare då livet kom ivägen igen.

Tänkte att jag skulle börja med att uppgradera från Fabriks firmware till nyaste. Men jag har testat både med Companion 2.0 och 2.3 men ingen vill flasha radion. Det står utförd men det enda som har hänt är att startskärmen är utbytt.

McRegor
2020-04-11, 21:49
Var lite försiktig för FrSky har nyligen kommit med en helt ny version av D16-protokollet som är helt inkompatibelt med tidigare versioner.
Roger

FinnbyFraggel
2020-04-11, 21:51
Var lite försiktig för FrSky har nyligen kommit med en helt ny version av D16-protokollet som är helt inkompatibelt med tidigare versioner.
RogerDet är skillnad på OpenTX och firmware för TX modulen.....

Skickat från min Armor_6E via Tapatalk

FinnbyFraggel
2020-04-11, 21:58
Ok. Testar igen ett år senare då livet kom ivägen igen.

Tänkte att jag skulle börja med att uppgradera från Fabriks firmware till nyaste. Men jag har testat både med Companion 2.0 och 2.3 men ingen vill flasha radion. Det står utförd men det enda som har hänt är att startskärmen är utbytt.Vilken version av OpenTX har din Taranis idag?
Har den 1.x krävs lite handpåläggning och driver i datorn.
Har den 2.x.x borde det inte var några större problem att gå upp till 2.2.x eller 2.3.x.
Notera att innehållet på SD kortet skiljer mellan dom olika OpenTX versionerna så ladda hem rätt innehåll för minneskort också.

Skickat från min Armor_6E via Tapatalk

McRegor
2020-04-11, 22:47
Det är skillnad på OpenTX och firmware för TX modulen.....

Skickat från min Armor_6E via Tapatalk'
Väldigt medveten om detta men det har tidigare talats om bl a EU-firmware i denna tråd och därför finns det anledning att varna eftersom FrSky kommit med D16 2.x
Roger

Pumpe
2020-04-12, 08:39
Vilken version av OpenTX har din Taranis idag?
Har den 1.x krävs lite handpåläggning och driver i datorn.
Har den 2.x.x borde det inte var några större problem att gå upp till 2.2.x eller 2.3.x.
Notera att innehållet på SD kortet skiljer mellan dom olika OpenTX versionerna så ladda hem rätt innehåll för minneskort också.

Skickat från min Armor_6E via Tapatalk

Den har orginal 1.1.02

Windows hittar både radion och minneskortet, jag har försökt uppdatera till de drivrutiner som finns på open tx hemsida men windows tycker att de bästa drivrutinerna redan är installerade.

Laddade hem den där zadig grejen men jag förstår inte hur jag ska göra med den.

McRegor
2020-04-12, 10:04
Ok - har du så gammal version av OpenTX i sändaren (och gissar jag motsvarande gammal firmware i modulen) så är det lite mera jobb än vanligt att uppdatera. Har själv tagit mig igenom detta men det är flera år sedan och såvitt jag minns följde jag nån anvisning jag hittade på nätet så det är nog bara att leta, tyvärr. Men sen du tagit dig igenom denna uppdatering så är det mycket enklare därefter. Men fortfarande kvarstår varningen för att inte firmware-uppdatera modulen till D16 v 2.xx för då måste du också uppdatera ALLA dina D16-mottagare till motsvarande version.
Roger

Gasman
2020-04-12, 12:00
Det lite pyssel att uppgradera från ver 1 till ver 2. Jag rotade fram en gammal tråd där jag beskrev tillvägagångsättet.
http://www.rcflyg.se/forum/showthrea...l=1#post385506 (http://www.rcflyg.se/forum/showthread.php/36595-FrSKY-TARANIS?p=385506&viewfull=1#post385506)

Lycka till!

Pumpe
2020-04-12, 14:00
Ok - har du så gammal version av OpenTX i sändaren (och gissar jag motsvarande gammal firmware i modulen) så är det lite mera jobb än vanligt att uppdatera. Har själv tagit mig igenom detta men det är flera år sedan och såvitt jag minns följde jag nån anvisning jag hittade på nätet så det är nog bara att leta, tyvärr. Men sen du tagit dig igenom denna uppdatering så är det mycket enklare därefter. Men fortfarande kvarstår varningen för att inte firmware-uppdatera modulen till D16 v 2.xx för då måste du också uppdatera ALLA dina D16-mottagare till motsvarande version.
Roger

Har nog försökt följa 10 olika guider. Problemet verkar vara att det inte går att installera rätt drivrutiner med zadig. stm32 går inte att välja. Jag har drivrutinen från open tx hemsida men jag lyckas inte installera den med zadig

McRegor
2020-04-12, 14:33
Pumpe - inte för jag vet om det blir nån skillnad men du har händelsevis inte en PC med lite äldre Win-version - typ Win 7 ?
Ibland fungerar det bättre med äldre grejor...:)
Roger

Pumpe
2020-04-12, 14:54
Testade en ny taktik. Följa samma guide flera gånger och efter 5-6 försök så verkar drivrutinerna fungera iaf.

Innan jag ens försöker uppdatera så tänkte jag att companion får göra en backup av firmware och den processen fastnade på 7% och har varit så i 10minuter...

Något jag inte riktigt förstår är vad som uppdateras. Hur väljer man att bara uppdatera radio och inte modul osv.

Pumpe
2020-04-12, 15:12
Testade att gå igenom alla steg igen och då fastnar backupen av gamla firmware på 4%

Någon som kan tänka sig vad felet är?

Pumpe
2020-04-12, 18:29
Pumpe - inte för jag vet om det blir nån skillnad men du har händelsevis inte en PC med lite äldre Win-version - typ Win 7 ?
Ibland fungerar det bättre med äldre grejor...:)
Roger

Jag ska försöka testa det. tyvärr var det win 8 och 10 på allt fungerande här hemma.

Funderar även på om det kan vara USB3 som spökar för det är det enda jag har på min dator. USB2 portarna är ur funktion.

Gasman
2020-04-12, 18:56
Som framgick i min länk jag postade här ovan fick jag det inte att funka förrän jag angav att datorn skulle köra programmet som kompatibelt med XP SP3.

McRegor
2020-04-12, 19:01
Vi kan i alla fall trösta dig med att sen du lyckats med denna uppdatering så är det enkelt sen, Pumpe...:)
Vill minnas att vi uppdaterade både min och kompisens Taranis samtidigt (gick från 1.x till 2.x) men att vi råkade ut för olika problem på de båda sändarna trots att vi körde på samma PC.
Roger

Pumpe
2020-04-12, 19:41
Som framgick i min länk jag postade här ovan fick jag det inte att funka förrän jag angav att datorn skulle köra programmet som kompatibelt med XP SP3.

Testade det också i början

Pumpe
2020-04-12, 20:05
Jag ska testa på en Win7 dator imorgon och se. Från vad jag har läst så verkar de iaf gå att få tillbaka om de har blivit brickade så det går nog bra om sändaren är hel.

Men om vi leker med tanken att det faktiskt fungerar. Hur fungerar det med rätt programvara i den interna modulen och mottagare? Är hyffsat säker på att det är V8FR-II mottagare jag har, och nån mindre VD5M

Ska modulen och mottagare uppdateras?

Fixar Companion SD kortet?