Reklam

 
Sidan 1 av 2 12 SistaSista
Resultat 1 till 20 av 37

Ämne: Problem att flasha om KK Kort!?

  1. #1

    Reg.datum
    Jun 2011
    Inlägg
    27
    Klubb
    Vänersborgs MFK

    Standard Problem att flasha om KK Kort!?

    Tjena.

    Har införskaffat ett HK multicopter KK kort V2 med 168 shippet på ihopp om att hotta upp min Y6:a med de senaste programvarorna.

    Kruxet är att när jag flashar i de senare programmvarorna så funkar inte kortet, lysdioden reagerar på armering på/av men reglagen bara piper underligt och ingenting går att ställa in. Så flashar jag tillbaka till gamla 1.1b osså funkar allt som det ska!

    Någon som vet vad som händer!?

    /Mvh Martin Lidén

  2. #2
    radioactives avatar
    Reg.datum
    Aug 2011
    Inlägg
    473
    Blogginlägg
    2
    Jobb
    Astronomi, RC-flyg, Multirotorflyg, Radio-DXing
    Klubb
    Fri och obunden skånepåg

    Standard

    Vet du om de senaste firmwaren/programmen fungerar till Hk v2? Låter som att de inte gör det fullt ut.

    Lasse

  3. #3

    Reg.datum
    Jun 2011
    Inlägg
    898
    Jobb
    Glödgare SSAB tunnplåt

    Standard

    Fungerar utmärkt för mig! Har som jag tidigare sagt installerat quad X 4.7


    Sent from my GT-I9000 using Tapatalk

  4. #4

    Reg.datum
    Jun 2011
    Inlägg
    898
    Jobb
    Glödgare SSAB tunnplåt

    Standard

    Du har kanske pottarna tvärtom, 100% blir 0% så du kommer in i nått inställningsläge? ställ in alla 3 på 50% och prova igen.

    Sent from my GT-I9000 using Tapatalk

  5. #5

    Reg.datum
    Jun 2011
    Inlägg
    27
    Klubb
    Vänersborgs MFK

    Standard

    Programmvaran skall funkera, väljer ju HK kk v2 i menyn och aktuella programvaror visas. Pottarna är det inte, inbillar mig att jag har koll på hur det skall funka, Kan ju hantera gamla 1.1b.

    Förfarandet skall vara samma i de nya programvarorna!?

    Det uppför sig helt ogerligt, piper med hög frekvens utan att det går att göra ngt.

  6. #6

    Reg.datum
    Jun 2011
    Inlägg
    898
    Jobb
    Glödgare SSAB tunnplåt

    Standard

    Har du kommit på det än ? Det gjorde jag efter att ha jävlats i några timmar! Välj "atmega 168p/pa" istället för "Hobbyking v2" i "Choose your controller" fönstret, om det står atmega 168 p eller pa på din krets då såklart... Misstänker att du också uppdaterar med KK multicopter flash tool.


    Mina motorer vägrade starta, gick dock att "arma" kortet. Efter att ha valt 168p/pa fungerade det direkt. Det lustiga är att jag har ett kort ifrån multircshop som också uppträder på samma vis. Måste ha blivit samma fel för dem när de flashade kortet! Hah!

  7. #7

    Reg.datum
    Jun 2011
    Inlägg
    898
    Jobb
    Glödgare SSAB tunnplåt

    Standard

    Det här problemet uppstod alltså på det andra KK-kortet jag köpte. Det första fungerade direkt! Måste ha varit ifrån en annan batch.

  8. #8
    rfnoises avatar
    Reg.datum
    Sep 2010
    Inlägg
    330
    Jobb
    IT
    Klubb
    Kungsholmen STHLM

    Standard

    Tja, jag byggde ihop en quad med ett KK Plus 5e kort igår. Första quaden för mig, har bara flugit tri innan. Jag trodde att mitt KK kort var skräp eller att jag hade blivit galen vid första testerna. Jag höll den krampaktigt över huvudet och vid minsta lutning vid 1/4 gas så drog några motorer fullt och quaden höll på att slitas ur min hand, phew. Testade allt men ingen förbättring. Trodde tillslut att jag hade för högt kv+för stora proppar(kda 20-26+10x4.5)

    Släppte skiten ett tag och funderade sen på att flasha med annan FW. Läste på lite innan och det visade sig att KK Plus har en annan fuse setting och att kortet med den rätta settingen finns i Kkflash tool. Jag valde atmel168 först. Läste också någonstans att aileron kabeln skulle vara ur vid flashningen? Hade något med boot loader att göra men jag har inte grävt mer i det.

    Nu funkar den perfekt!

    /Calle
    Det går alltid att bygga om och bygga bättre!

  9. #9

    Standard

    Bra tips ,,Tack ska du ha ,,Spar nog ett antal timmar ..ska kolla mitt efter jul...
    ================================================== ==================

    Alldeles för många plan i garaget

  10. #10

    Standard

    Citat Ursprungligen postat av rfnoise Visa inlägg
    Tja, jag byggde ihop en quad med ett KK Plus 5e kort igår. Första quaden för mig, har bara flugit tri innan. Jag trodde att mitt KK kort var skräp eller att jag hade blivit galen vid första testerna. Jag höll den krampaktigt över huvudet och vid minsta lutning vid 1/4 gas så drog några motorer fullt och quaden höll på att slitas ur min hand, phew. Testade allt men ingen förbättring. Trodde tillslut att jag hade för högt kv+för stora proppar(kda 20-26+10x4.5)

    Släppte skiten ett tag och funderade sen på att flasha med annan FW. Läste på lite innan och det visade sig att KK Plus har en annan fuse setting och att kortet med den rätta settingen finns i Kkflash tool. Jag valde atmel168 först. Läste också någonstans att aileron kabeln skulle vara ur vid flashningen? Hade något med boot loader att göra men jag har inte grävt mer i det.

    Nu funkar den perfekt!

    /Calle
    Precis som du skriver så beter sig min oxå!!
    Kör du med kk plus tool programmet? Vilken FW laddade du ner? jag har laddat ner v4.7X från www.multircshop.com
    och laddat in v_4_7_X_M168_M328.hex i mitt kort. Är det alltså den andra hexfilen som heter 48 nånting man ska ladda in Plus kortet då? blir ju lite *PIIIIP* på de här. Mvh Fredde

  11. #11
    rfnoises avatar
    Reg.datum
    Sep 2010
    Inlägg
    330
    Jobb
    IT
    Klubb
    Kungsholmen STHLM

    Standard

    Tjena!

    Jag bytte till + konfig, valde KK Plus kortet i "Choose your controller" i http://lazyzero.de/en/modellbau/kkmulticopterflashtool där jag hade valt atmega 168 innan, valde online versionen av Quadrocopter V4.7 m168 - Kommer sen att flasha om med Xcopter 4.7 online.

    Just det, jag läste något om att aileron kablen ska vara ur här: http://www.rcgroups.com/forums/showthread.php?t=1445151

    Där kör de KK plus verktyget och med BEC men jag körde utan BEC och med kkflashtool och urdragen aileronkabel

    Good luck!
    Det går alltid att bygga om och bygga bättre!

  12. #12

    Standard

    ok..ska pröva. Jag har en mkusb som jag flashar med..vad ska jag välja för programmerare då?

  13. #13
    rfnoises avatar
    Reg.datum
    Sep 2010
    Inlägg
    330
    Jobb
    IT
    Klubb
    Kungsholmen STHLM

    Standard

    Tjena, mkusb funkar inte med med KKflashtool tyvärr. Kör KK plus tool men ta bort aileron kabeln. Du kanske behöver ge kortet ström innan flashningen också?
    Det går alltid att bygga om och bygga bättre!

  14. #14

    Standard

    Prövade flash tool men fick det inte att funka som du säger. Har flashat mitt i kk plus tool precis som efter den här filmen



    Och programmet säger att allt är i sin ordning men jag får fan inte skiten att funka. De är 4.7 som jag laddat in,kanske ska pröva med någon annan. Men när man kör X mode..ska kablarna från mottagaren monteras annorlunda då eller nått? typ Ail på kortet ska in i elev på mottagren? bara en teori som säkert inte alls stämmer. Blir bara j***t trött på de här nu Fredde
    Senast redigerat av administrator den 2011-12-29 klockan 21:19.

  15. #15

    Standard

    Tjena Fredde.
    alla kablar ska sitta precis som vanligt,ele-ele,ail-ail osv.oavsett programvara.
    får du ingen ordning på det kan du skicka hit det så kan vi se om jag kan fixa i ny programvara åt dig.

    Kör KK flashtool från lazy zero.
    har Flashat både HK kort.Svarta 5.5 o Hemmasnickrade gröna från hubben.varit strul en gång när man valt fel processor sort,då det blivit fel fuse setting,men funkar bara man flashar om till rätt..

    hade du testat efter "steffes" inlägg ovan,och ändå inte fått nån bättring?.
    förstår inte "riktigt" hur det uppför sig?.när du flashat det säger Flashprogrammet att allt blev ok vid flashning?.
    om så,vad /hur låter kortet när du "bara"ansluter spänning?(ej armerar)..

    //Patrik.

  16. #16

    Reg.datum
    Jun 2011
    Inlägg
    898
    Jobb
    Glödgare SSAB tunnplåt

    Standard

    Har du rätt ordning på motorerna? Det är inte samma ordning på de olika mjukvarorna.

    X-mode setup KK 4.7:

    Motor 1: front left, CW
    Motor 2: back left, CCW
    Motor 3: Front right, CCW
    Motor 4: Back right, CW

    http://www.rcgroups.com/forums/showt...1458663&page=5

  17. #17

    Reg.datum
    Jun 2011
    Inlägg
    898
    Jobb
    Glödgare SSAB tunnplåt

    Standard

    Hittade på de här roliga projekten med KK-kort:

    KK control board aeroplane:
    http://www.rcgroups.com/forums/showthread.php?t=1554249

    Nextcopter autolevel KK-board:
    http://www.rcgroups.com/forums/showthread.php?t=1526268

  18. #18

    Reg.datum
    Jun 2011
    Inlägg
    898
    Jobb
    Glödgare SSAB tunnplåt

    Standard

    Kom på en till grej. Använder min nya Turnigy 9x radio med er9x mjukvara till quadden. En sak som jäklades ett tag var att ordningen på kanalerna inte var likadan som på mina gamla hitec samt Hobbyking sändare. Kolla att du verkligen sätter sladdarna på rätt ställe mellan mottagaren och KK-kortet. Stoppa i servon i mottagaren om du är osäker på vilken spakrörelse som hamnar vart.

  19. #19

    Standard

    Hej igen grabbar

    De du skriver Steffe måste vara felet. Jag har kopplat motorena enligt rcexplorers sida om X quad ocg de är ju inte alls som du skriver. Tanken har slagit mig att de måste vart de som är felet men har dubbel checkat att jag kopplat precis som han beskriver säkert 100 ggr Och allt har ju reagerat helt fel när jag haft den över huvudet så har ju allt kompenserat fel och vart helt galen. Ska testa senare ikväll och ladda in FW igen och börja om från början och testa.

    Skulle de nu inte funka så kommer ett kort till dig Patrik Fast jag är övertygad om att de kommer funka nu. Återkommer. Fredde

  20. #20

    Standard

    Hej igen

    Nu har jag fixat den..allt verkar fungera skysst nu. Har iofs bara hovrat lite i källaren.. men den funkar. Vart så till mig när jag skrev de förra inlägget så jag ser nu hur knäppt allt är formulerat Men de funkar!!! äntligen kan man ha med sig en busfpv quad i lastbilen på dagarna

    Steffe du kanske kan svara på då vilket nr som är vad på en Turnigy9x mottagare. Har en spritt ny som ligger som jag tänkte ha som slit o släng. Fredde

Liknande ämnen

  1. Flasha om KK2 kort!
    Av kajakmannen i forum Elektronik-Mjukvara-Hårdvara
    Svar: 29
    Senaste inlägg: 2013-09-02, 09:08
  2. Problem flasha ESC
    Av magnusvr i forum Radiostyrning, powerboxar, mottagare, servon, gyro mm
    Svar: 8
    Senaste inlägg: 2013-07-15, 22:59
  3. Problem med uppgradering kk-kort
    Av Elia i forum Elektronik-Mjukvara-Hårdvara
    Svar: 13
    Senaste inlägg: 2012-10-11, 07:51
  4. Flasha om ESC
    Av Elia i forum Allmänt
    Svar: 2
    Senaste inlägg: 2012-09-21, 08:58
  5. Problem - Flasha HK-kort
    Av radioactive i forum Elektronik-Mjukvara-Hårdvara
    Svar: 8
    Senaste inlägg: 2011-11-22, 00:06

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •