Reklam

 
Resultat 1 till 15 av 15

Ämne: KK2.1 Openaero2 som hänger sig.

  1. #1

    Standard KK2.1 Openaero2 som hänger sig.

    Hej
    Flashade in Openaero på en KK2.1 jag hade över och slängde in den i mitt FPV-plan.
    Allt har fungerat bra men idag plötsligt sluta planet svara och den parkerade fint i ett träd.
    När jag kom in och kollade in vad som hänt så upptäckte jag att KK2.1 var igång men displayen var helt blank.
    Ryckte ur strömmen och kopplade in den igen men ingen skillnad.
    Efter drygt 5min så startade den helt plötsligt och allt ser ut att vara som det ska igen.
    Någon som har erfarenhet av detta märkliga uppträdande av KK2 eller KK2.1?
    MVH
    Marcus

  2. #2

    Reg.datum
    Oct 2010
    Inlägg
    291
    Jobb
    Vindkraftverkstekniker
    Klubb
    Hemma på gårn

    Standard

    Har du seperat strömförsörjning till kortet, så det inte delar bec med servona? Annars så kraschar processorn rätt så lätt. Det är det första jag kom att tänka på iaf. Posta i rcgroups tråden oxo, så kanske happysunday kan hjälpa dig.

  3. #3

    Standard

    Känns som det kan ha något att göra med spänningsmatningen.
    Jag har dubbla spänningsmatningar men ESCn som sitter i min FPV Raptor är känd för att gå sönder.
    Det konstiga är dock att efter jag bytte till en annan ESC så startade den inte iallafall.
    Bytte tillbaka ESCn och efter lite vila så kickade den plötsligt igång.
    Ska nog ta och byta ESCn till en annan och testa igen.
    /Marcus

  4. #4

    Reg.datum
    Oct 2010
    Inlägg
    291
    Jobb
    Vindkraftverkstekniker
    Klubb
    Hemma på gårn

    Standard

    Förser du kortet med den inbyggda becen i escn ? Prova å köra tvärtom. Servona på escns bec å kortet på en egen bec. Så gör jag iaf

  5. #5

    Standard

    Kör du inte Throtteln genom KK2 då utan direkt på RX?
    Vilken firmware kör du?
    Förresten vad kör du för inställningar på P I?
    Tycker den kompeserar för lite med default men har inte ändrat något ännu.
    /Marcus

  6. #6

    Reg.datum
    Oct 2010
    Inlägg
    291
    Jobb
    Vindkraftverkstekniker
    Klubb
    Hemma på gårn

    Standard

    Jag kör med ppm mottagare på min. Har iofs kk2.0, förser själva kortet med ström från egen bec genom mottagaren. Sedan en bec på servosidan av kortet. De är ju inte ihopkopplade, mottagarsidan och servosidan. Just för att kortet lätt kraschar om det får störningarna från servona på mottagarsidan av kortet. Kolla igenom guiden på happusundays google code sida så ser du hur man ska göra. Pid har jag inte ändrat, däremot har jag variabel gain på en ratt på sändaren som funkar klockrent

  7. #7

    Standard

    Tror tyvärr inte jag kan byta plats på BEC från ESCn och den separata BECn.
    Detta efterssom M1 samtidigt är utgången som styr ESCn och sin tur motorn.

    Detta stämmer enligt Googgle code sidan:
    KK2 Board

    A 5 volt regulated power supply must be connected to the pin marked M1. Typically, this will be the 5 volt supply from the ESC's internal BEC. This will provide power to both the KK2 board and the receiver.
    Servos

    A second BEC must be connected to any of the pins marked M2-M8, to power the servos. Depending on the specification of your servos, typically a 5 to 6 volt external BEC will be used.

  8. #8

    Reg.datum
    Oct 2010
    Inlägg
    291
    Jobb
    Vindkraftverkstekniker
    Klubb
    Hemma på gårn

    Standard

    Okey, jag har två becar då escn på min mpx twister ej har ngn inbyggd. Löste det genom en ykabel. Men då verkar det inte vara strömförsjning som ställer till det för dig. Eller så är den i ditt esc lite knepig alternativt håller på att gå sönder. Men fråga på tråden i rcgroups. Killarna där har koll på hur både mjukvaran å kortet fungerar.

  9. #9

    Reg.datum
    Oct 2010
    Inlägg
    291
    Jobb
    Vindkraftverkstekniker
    Klubb
    Hemma på gårn

    Standard

    http://www.rcgroups.com/forums/showthread.php?t=1708175
    OpenAero2 open-source stabilisation software for KK2 boards
    Där har du den, men du har säkert länken redan

  10. #10

    Standard

    Bytte ESC idag. Det var nog den som var skumm. Luktar bränd elektrolytkonding:-)
    Märkligt nog så kunde jag inte kalibrera nya ESCn när den var kopplad på KK2.1an så jag flyttade escn till RXn.
    Tydligen matas KK-kortet via RXn iallafall och det verkar fungera utmärkt.
    Har tömt en ack i verkstaden nu och allt verkar stabilt.

    Apropå gain. Hur mycket brukar du köra med ? Med default inställningen så rör sig skevrodren knappt något alls.
    Kör du autolevel också? Upplever att autolevel motkompenserar när man svänger så man får mindre utslag.

    /MA

  11. #11

    Reg.datum
    Oct 2010
    Inlägg
    291
    Jobb
    Vindkraftverkstekniker
    Klubb
    Hemma på gårn

    Standard

    Man kan nog inte kalibrera på ett bra sätt med kk2an, tyvärr. Gainen är nog väldigt olika för olika flygetyg. Sätt den på en pot på radion så kan du ju snurra dig fram till rätt gain tänk på att högre hastigheter kräver lägre gain än låga hastigheter, annars oscillerar flyget med hög gain och hög hastighet. Jag kör endast i stability läget, och skevrodren rör sig rätt mkt när jag rollar flygplanet på backen

  12. #12

    Standard

    Jag får köra in Gain-styrningen på en Pot precis som du och köra och testa helt enkelt.
    Tack för all hjälp
    /Marcus

  13. #13

    Reg.datum
    Oct 2010
    Inlägg
    291
    Jobb
    Vindkraftverkstekniker
    Klubb
    Hemma på gårn

    Standard

    Ingen fara. Bara kul att någon annan har upptäckt openaero2, den slår lätt de flesta andra produkter på fingrarna

  14. #14

    Standard

    Flög på lunchen idag igen.
    Efter 1ack utan problem så bytte jag ack och körde igen.
    Felet uppstod igen men ingen skada skedd.
    Tror något måste vara galet med denna KK2.1 så nu ger jag upp.
    Hittar ingen annan som kör 2.1 så jag tror jag ska skifta till en kk2.0 eller alternativt vänta tills min APM2.6 dyker upp.

    /Marcus

  15. #15

    Standard

    Har nu flashat in Openaero2 på en KK2.0 istället.
    Funkar klockrent!
    Flyttade även KK2.1 till min Quad och den fungerade också utmärkt.
    Min KK2.1 gillar helt enkelt inte Openaero.....
    /Macke
    Senast redigerat av mackez den 2014-02-05 klockan 19:20.

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •