Reklam

 
Sidan 14 av 19 FörstaFörsta ... 4910111213141516171819 SistaSista
Resultat 261 till 280 av 364

Ämne: Funfly Naze32 / AfroMini

  1. #261

    Reg.datum
    Apr 2013
    Inlägg
    72
    Blogginlägg
    1
    Jobb
    IT Pro
    Klubb
    Lindsdals Radioflygklubb - Kalmar

    Standard

    Obs. Mata bara nazen med ström från en av esc.erna...

  2. #262

    Standard

    Testade cleanflights autotune och det fungerar ju faktiskt rätt bra. Kan bara aktivera autotune i angle men det är kanske så det ska vara.

    Men jag blev lite konfunderad när jag testade angle och horizon, det var bara i angle som quaden återgick till planflykt när jag släppte upp spakarna, ska den inte göra det i horizon också?

    Jag flyger med senaste stabila versionen av cleanflight.
    Senast redigerat av Boopidoo den 2015-03-31 klockan 19:28.

  3. #263

    Reg.datum
    Apr 2013
    Inlägg
    72
    Blogginlägg
    1
    Jobb
    IT Pro
    Klubb
    Lindsdals Radioflygklubb - Kalmar

    Standard

    Också provat autotune, ger ok startvärden. Och horizon för mig ger exakt samma som angle om jag släpper spakarna. Säker på att du kör horizon?
    Har 2 nybyggda minis, 1 220 för losträning och senare 3d och en zmr250, valde harakirivägen på dem. Satan vilken skillnad! Värt att testa

  4. #264

    Standard

    Haha, det skulle ju vara kul om jag trodde att jag körde det fast det egentlig var strong. Var lite nervös i acro men slappnade av när jag kopplade in horizon. Skulle ju vara kul om jag egentligen kört acro hela tiden.

    Har fipplat med inställningar och olika modes ett tag så det är ju inte helt otroligt att jag missade att ställa in horizon korrekt.

    Det som var jobbigast med autotune var att den gled iväg så fort med vinden. Det blåste en del så jag fick hela tiden avbryta och starta om. Vet ni om den har vid där den var eller börjar om? Jag antar att den ändrar värdena live så det blir väl inte en helt från början men den hinner nog inte köra hela programmet.

  5. #265

    Standard

    Idag testade jag med att mata nazen med en separat bec för att sedan koppla in accen. Då startar escarna som dom skall.
    Drar sedan ur becen för att kunna flyga,vilket fungerar.
    Så det verkar som om att mina escar inte tycker om att allt startar samtidigt.
    Kan man lura escarna eller är det bara att köpa nya "bättre" ?
    skall undertiteln testa att bara mata med en esc och se om det hjälper

  6. #266

    Reg.datum
    Apr 2013
    Inlägg
    72
    Blogginlägg
    1
    Jobb
    IT Pro
    Klubb
    Lindsdals Radioflygklubb - Kalmar

    Standard

    Boopidoo: det har ändrats i senare versioner hur det funkar med autotune så du får kog dubbelkolla docs. Men jag var tvungen att plugga in dator (bluetooth funkar med) och köra en save.

    Masv. Testa att använda en av de andra escerna att mata nazen med ifall de e lite för hög eller låg spänning, alternativt jittrig som den kan vara ibland

  7. #267

    Standard

    Citat Ursprungligen postat av Borren Visa inlägg
    Boopidoo: det har ändrats i senare versioner hur det funkar med autotune så du får kog dubbelkolla docs. Men jag var tvungen att plugga in dator (bluetooth funkar med) och köra en save.
    Hur menar du, sparas inte värdena i Nazen utan att gå via en dator? Känns ju extremt knöligt.

  8. #268

    Standard

    Har dubbelkollat nu och visst "borde" horizon ha fungerat som den skulle, nu är ju bara frågan om varför den inte gjorde det. Den röda LED som visar att det stabiliserat läge är aktiverat lyser för både ANGLE och HORIZON. Finns det någon inställning som avgör hur "stabilt" den ska flyga i HORIZON?

    Lyckades för övrigt hitta mina inställningar från autotune, de var ju inte längre kvar på Naze32 men de fanns som tur väl var sparade i EZ-GUI appen på min telefon. Så det var bara att ladda ner till kortet så fanns de där.

    Förresten, vet någon om hur man ändrar PID modes (1,2,3) i EZ-GUI? Jag hittar ingen sådan valruta och det skulle ju vara smidigt att kunna välja.

  9. #269

    Standard

    Citat Ursprungligen postat av Boopidoo Visa inlägg
    Lyckades för övrigt hitta mina inställningar från autotune, de var ju inte längre kvar på Naze32 men de fanns som tur väl var sparade i EZ-GUI appen på min telefon. Så det var bara att ladda ner till kortet så fanns de där.

    Förresten, vet någon om hur man ändrar PID modes (1,2,3) i EZ-GUI? Jag hittar ingen sådan valruta och det skulle ju vara smidigt att kunna välja.
    Om du vill spara inställningarna direkt efter autotune så är det bara att landa när du gjort klart autotune processen och disarma. Därefter aktiverar du autotune igen när quaden är disarmad så sparas de permanent. Har man en buzzer inkopplad så piper den också då med en bekräftelse. Drar man ur batteriet innan man sparat på detta vis försvinner de nya pidarna.

    Med PID modes menar du då de tre olika pidkonfigurationen man kan ha, eller menar du de olika typerna av Pid regulatorer som finns?
    TBS Discovery m. gimbal för finflygning, ZMR250 för fulflygning

  10. #270

    Standard

    Ok, tack för tipset. Ja, jag menar de tre olika PID-konfigurationerna.

  11. #271

    Standard

    Citat Ursprungligen postat av Boopidoo Visa inlägg
    Ok, tack för tipset. Ja, jag menar de tre olika PID-konfigurationerna.
    Ja, det kan man ändra väldigt lätt via radion!

    Håll vänstra spaken neråt till vänster. När du gör det så flyttar du den högra spaken rakt till vänster för profil 1, rakt upp för profil 2 och rakt höger för profil 3. Har du buzzer så piper den också 1-3 gånger för att bekräfta vilken profil du valt. Tror även en lampa på nazen blinkar 1-3 gånger också beroende på vilken profil du valt.

    Allt detta ska man såklart göra när den är disarmed.

  12. #272

    Standard

    Tackar

  13. #273

    Standard

    Har precis testflugit och har insett några saker.

    Det är mycket svårt att ställa in PID när det blåser en massa, särskilt på en liten 250.

    Horizon fungerar inte. Naze32 indikerar att den aktiveras (dvs röd LED) men den beter sig exakt som ACRO. I ANGLE så beter den sig som den ska dock.

  14. #274

    Reg.datum
    Apr 2013
    Inlägg
    72
    Blogginlägg
    1
    Jobb
    IT Pro
    Klubb
    Lindsdals Radioflygklubb - Kalmar

    Standard

    Hehe dom driver rätt bra i vinden... Testa att kalibrera gyrot en gång till. Jag har haft lite spök med det tidigare. Hjälper inte det får du nog kolla om nån på #cleanflight på irc kan ge bättre förslag

  15. #275

    Standard

    Då jag experimenterat med så många konstiga grejer så valde jag att göra en "ominstallation" när jag lade in Cleanflight 1.7.2. Inget i hårdvaran är ändrat men helt plötsligt vill quadden ha map AETR1234 istället för map TAER1234 som man brukar med Orange 615X mottagare och RX_PPM. Jag kollade till och med backupen som jag tog den 28e December och där använde jag TAER1234.

    Efter att ha flashat om och konfigurerat från scratch igen så har jag valt att ge upp, den fungerar ju perfekt. Det är bara att vara vaksam vid nästa uppgradering. Spännande!

  16. #276

    Standard

    Hmm, jag ska testa att omkalibrera gyrona men annars är det väl bara ominstallation kvar antar jag. Jag har försökt leta på fenomenet att Horizon inte fungerar trots att den aktiveras men inte hittat något vettigt.

  17. #277

    Reg.datum
    Apr 2013
    Inlägg
    72
    Blogginlägg
    1
    Jobb
    IT Pro
    Klubb
    Lindsdals Radioflygklubb - Kalmar

    Standard

    Bara spara en dump samt ev rateprofiles och pid profiler, lätt att glömma dom. Så kan man snabbt få in alla sina grundinställningar. Jag har en separat lista med alla parametrar jag brukar använda och rateprofile 0/1/2 samt led konfig. Bara att flasha med "wipe settings" och sen klistra in allt i cmdline sånär man klar att köra igen. Vore fint om dom kunde fixa så backup funktionen sparade allt och inte bara kalibreringsdata och grundkonf

  18. #278

    Standard

    Nu har jag ju precis börja ställa in den så det är inte så mycket att spara men tack för tipset. Jag har några Acro Naze32 liggandes och detta är en sk Full Naze32 som jag hade tänkt para ihop med en OSDoge så det vore trist om det är något knas med kortet.

  19. #279

    Standard

    Jag fick rådet på labbet att öka self-level gains för att få igång Horizon. Ska testa det först.

  20. #280

    Standard

    Får jag gissa att du använder PID1 controllern? Jag har provat några olika controllers idag för att bli av med det jitter jag dragits med på min Gekko med 1306 motorer. Jag fann då att PID1 har andra Level inställningar och att auto level blir extremt svag om man bara slår över till PID1 utan att ändra något. Det hann bli mörkt innan jag hittade det här så jag har inte fått det att fungera ännu. set p_level = 20 och set i_level = 80 gjorde ingen märkbar skillnad.

    Jittret försvann med PID1!

    PID controller 1, "Rewrite"

    PID Controller 1 is a newer PID controller that is derived from the one in MultiWii 2.3 and later. It works better from all accounts, and fixes some inherent problems in the way the old one worked. From reports, tuning is apparently easier on controller 1, and it tolerates a wider range of PID values well.
    Unlike controller 0, controller 1 allows the user to manipulate PID values to tune reaction and stability without affecting yaw, roll or pitch rotation rates (which are tuned by the dedicated roll & pitch and yaw rate settings).
    In Angle mode, this controller uses the LEVEL "P" PID setting to decide how strong the auto-level correction should be. Note that the default value for P_Level is 90. This is more than likely too high of a value for most, and will cause the model to be very unstable in Angle Mode, and could result in loss of control. It is recommended to change this value to 20 before using PID Controller 1 in Angle Mode.
    In Horizon mode, this controller uses the LEVEL "I" PID setting to decide how much auto-level correction should be applied. The default Cleanflight setting for "I" will result in virtually no auto-leveling being applied, so that will need to be increased in order to perform like PID controller 0.
    The LEVEL "D" setting is not used by this controller.
    TPA is not used by this controller.

    Källa: https://github.com/cleanflight/clean...ID%20tuning.md

    Default värden:
    set p_level = 90; Visas som 9.0 I cleanflight configurator
    set i_level = 10; Visas som 0.010 i Cleanflight configurator.
    Senast redigerat av Jorgen den 2015-04-02 klockan 22:00.

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •