Reklam

 
Sidan 5 av 19 FörstaFörsta 1234567891015 ... SistaSista
Resultat 81 till 100 av 364

Ämne: Funfly Naze32 / AfroMini

  1. #81

    Reg.datum
    Oct 2010
    Inlägg
    291
    Jobb
    Vindkraftverkstekniker
    Klubb
    Hemma på gårn

    Standard

    I default så går motorerna på "tomgång" när den är armerad

  2. #82

    Standard

    Nu har även RMRC fått Naze Acro ! Det är najs då det är en väldigt bra butik.

    Med pinnar (böjda / raka)

    http://www.readymaderc.com/store/ind...oducts_id=3061

    http://www.readymaderc.com/store/ind...oducts_id=3077

    Utan pinnar

    http://www.readymaderc.com/store/ind...oducts_id=3066

    Breakout kabel

    http://www.readymaderc.com/store/ind...oducts_id=3062
    Senast redigerat av Copterdude den 2014-07-10 klockan 10:08.

  3. #83

    Standard

    Citat Ursprungligen postat av Xermalk Visa inlägg
    Fick precis hem min Armattan mini vtail.
    När jag aktiverar arm så varvar motorerna direkt upp, verkar lite konstigt då den är inställd och testflugen innan den skeppades.
    Behöver jag kalibrera om motorerna eller ? Enligt rx menyn i baseflight configurator så är min throttle range 993-2025 vilket verkar normalt nog.


    Bifogad fil 46523
    Öppna baseflight
    Anslut naze och klicka connect
    Öppna CLI
    Skriv "feature motor-stop"
    Skriv "save"
    Stäng CLI
    Klicka Disconnect
    Koppla från Naze

  4. #84
    markusbs avatar
    Reg.datum
    Jun 2009
    Inlägg
    1 407
    Jobb
    Servicetekniker el/elektronik/maskiner

    Standard

    Theailer var vänlig och skickade sina trasiga näsor till mig.
    Har felsökt dom och kan konstatera att någon/några av utgångspinnarna från cpun har pajjat på samtliga kort.
    Dvs pinnarna som är anslutna till kontakterna för fartreglage/servon.
    Dom brunna utgångarna är kortslutna och mäter ca 3-5ohm mot jord.
    Vid uppstart av ett trasigt kort blir regulatorn grisavarm.

    Jag har lyssnat med timecop om detta och enligt honom är det en så enkel operation som att byta cpu, bygla bootloaderpinnarna och tanka i ny fw.
    Vi får se om det är så enkelt, för nu är en knippe STM-kretsar på väg hem från ebay.

    Jag funderar fortfarande på vad som orsakat detta på samtliga kort?
    Det enda jav kan tänka mig är antingen en hög spänning in på utgångspinnarna alternativt en kortsluten utgång. Har ej kollat databladet om STM är kortslutningsskyddad på pinnarna, men jag skulle tippa på att den är det.
    Eller är det en ESD smäll kanske?

    Är det fler som lyckats elda sina kort på liknande sätt?
    Är nyfiken på att ta reda på om det finns en annan orsak, att dom är känsliga för något yttre eller liknande. Det kanske inte beror på det jag tror.

    Theailer, har du en ny naze monterad och ok nu?
    kom du på exakt orsak och lösning isf?

  5. #85

    Standard

    Tackar, men tror jag lämnar den på. Rätt skönt att ha motorerna som en indikering på om den är armed.

    Finns där någon bra guide för pid inställningarna? Min mini vtail behöver definitivt bättre pids.



    Nuvarande pids
    Klicka på bilden för en större version. 

Namn:	test 1.jpg 
Visningar:	68 
Storlek:	76,8 KB 
Id:	46580

    Flygvikt 700g, 4x cobra 1960 motorer på 4s. Med HQ6030 proppar.


    Citat Ursprungligen postat av Boopidoo Visa inlägg
    Öppna baseflight
    Anslut naze och klicka connect
    Öppna CLI
    Skriv "feature motor-stop"
    Skriv "save"
    Stäng CLI
    Klicka Disconnect
    Koppla från Naze
    Senast redigerat av administrator den 2014-07-28 klockan 10:10.

  6. #86

    Standard

    Jag flög lite idag och märkte att min drar sig ganska rejält i både roll och yaw.

    Finns det någon bra läsning med steg för steg för inställning av PID samt vad man bör ställa in först? Som det är nu så gissar jag mest och drar ner när det vibrerar för mycket men jag är inte alls nöjd. Jag trodde jag var det men det var innan jag upptäckte hur mycket den drar sig. Det känns som om det har börjat ske nyligen.

  7. #87
    dvogonens avatar
    Reg.datum
    Jul 2012
    Inlägg
    493
    Jobb
    Programutvecklare
    Klubb
    Tullinge MF

    Standard

    Citat Ursprungligen postat av markusb Visa inlägg
    Theailer var vänlig och skickade sina trasiga näsor till mig.
    Har felsökt dom och kan konstatera att någon/några av utgångspinnarna från cpun har pajjat på samtliga kort.
    Dvs pinnarna som är anslutna till kontakterna för fartreglage/servon.
    Dom brunna utgångarna är kortslutna och mäter ca 3-5ohm mot jord.
    Vid uppstart av ett trasigt kort blir regulatorn grisavarm.

    Jag har lyssnat med timecop om detta och enligt honom är det en så enkel operation som att byta cpu, bygla bootloaderpinnarna och tanka i ny fw.
    Vi får se om det är så enkelt, för nu är en knippe STM-kretsar på väg hem från ebay.

    Jag funderar fortfarande på vad som orsakat detta på samtliga kort?
    Det enda jav kan tänka mig är antingen en hög spänning in på utgångspinnarna alternativt en kortsluten utgång. Har ej kollat databladet om STM är kortslutningsskyddad på pinnarna, men jag skulle tippa på att den är det.
    Eller är det en ESD smäll kanske?

    Är det fler som lyckats elda sina kort på liknande sätt?
    Är nyfiken på att ta reda på om det finns en annan orsak, att dom är känsliga för något yttre eller liknande. Det kanske inte beror på det jag tror.

    Theailer, har du en ny naze monterad och ok nu?
    kom du på exakt orsak och lösning isf?
    Jag har inte eldat upp några naze-kort (än), men väl tre stycken kk2-kort. Exakt samma problem som du beskriver med motorpinnar som inte funkar. Jag tror att jag till slut hittade felet. En av mina ESCer hade en dålig lödning på +kabeln till batteriet. En tråd spretade ut och om man tryckte hårt på ESCn kortslöts batteri+ till signaljord. Korten gick alla tre sönder vid hårda landningar. Jag kan mycket väl tänka mig att anslagen var nog för att det skulle bli en strömspik. Trist.

  8. #88

    Reg.datum
    Oct 2010
    Inlägg
    291
    Jobb
    Vindkraftverkstekniker
    Klubb
    Hemma på gårn

    Standard

    Markusb: hade kunna servon på en 6volts bec och då matade servona även 6v över signal. Det räckte för att näsan skulle brinna upp efter ett tag. Vissa dog direkt medan andra tog lite tid på sig

  9. #89

    Standard

    Apropå PID-tuning så hittade jag det här som jag tycker verkar vettigt. Blir till att börja om från början och arbeta mig uppåt till vettiga inställningar.

    http://blog.oscarliang.net/quadcopte...lained-tuning/

  10. #90

    Standard

    Ska det gå att ansluta Naze32 till EZ-GUI mha USB? Jag har försökt men det verkar inte gå?

    EDIT: Jag löste det. Av någon anledning fungerade det inte först.
    Senast redigerat av Boopidoo den 2014-07-12 klockan 20:37.

  11. #91

    Standard

    Jag har precis börjat konfa min Full Naze32 och jag inser snabbt att jag måste rotera den 90 grader för att få lättare åtkomst till USB-kontakten. Efter lite googlande verkar det som att följande ska fungera.

    Set align_board_yaw=90


    Efter kontroll så kan jag se att korter "rör" sig på rätt sätt i chrome baseflight. Nu är dock frågan om jag även måste rotera annat för att det ska fungera eller om detta kommandot räcker, exempelvis magnetometern? Jag blir lite konfunderad eftersom acc, gyro och mag inte verkar ha ändrats.

    align_gyro = 0
    align_acc = 0
    align_mag = 0
    align_board_roll = 0
    align_board_pitch = 0
    align_board_yaw = 90

  12. #92
    markusbs avatar
    Reg.datum
    Jun 2009
    Inlägg
    1 407
    Jobb
    Servicetekniker el/elektronik/maskiner

    Standard

    Det räcker. Gjorde det för bara ett par timmar sedan på en full naze som nu sitter på trikoptern.
    Glöm inte kalibrera acc och mag sedan.

  13. #93

    Standard

    Ah just det kalibrera mag, det har jag inte gjort men det ska väl inte vara så svårt. Jag väntar tills den sitter på flygetyget först dock. Lite pilligt att göra med bara kortet.

  14. #94

    Reg.datum
    Oct 2010
    Inlägg
    291
    Jobb
    Vindkraftverkstekniker
    Klubb
    Hemma på gårn

    Standard

    Tycker det är lättare med bara kortet. Bara att snurra på sladden

  15. #95
    markusbs avatar
    Reg.datum
    Jun 2009
    Inlägg
    1 407
    Jobb
    Servicetekniker el/elektronik/maskiner

    Standard

    Precis, en roll, en flipp och ett varv runt i rondellen så är det klart.
    En sista acc cal när allt är monterat och står plant.

  16. #96

    Standard

    Nu har jag installerat senaste FW samt börjat om från början. Tog grundinställningarna, sänkte PID, och ökade tills det kändes bra. Det blir fortfarande lite "ryck" ibland men jag vet inte vad jag riktigt ska ändra för att det ska försvinna. Man ser det i videon men märks inte när jag flyger. Rent generellt kan sägas att min P är riktigt låga (~2.5) och I ganska höga (~50).
    aux 0 0
    aux 1 2
    aux 2 4
    aux 3 2
    aux 4 0
    aux 5 0
    aux 6 0
    aux 7 0
    aux 8 0
    aux 9 0
    aux 10 0
    aux 11 0
    aux 12 0
    aux 13 0
    aux 14 0
    aux 15 0
    aux 16 0
    aux 17 0
    aux 18 0
    aux 19 0
    aux 20 0
    mixer QUADX
    feature -PPM
    feature -VBAT
    feature -INFLIGHT_ACC_CAL
    feature -SERIALRX
    feature -MOTOR_STOP
    feature -SERVO_TILT
    feature -SOFTSERIAL
    feature -LED_RING
    feature -GPS
    feature -FAILSAFE
    feature -SONAR
    feature -TELEMETRY
    feature -POWERMETER
    feature -VARIO
    feature -3D
    feature PPM
    feature VBAT
    feature MOTOR_STOP
    feature SERVO_TILT
    map AETR1234
    set looptime = 2500
    set emf_avoidance = 1
    set midrc = 1520
    set minthrottle = 1050
    set maxthrottle = 1850
    set mincommand = 1000
    set mincheck = 1100
    set maxcheck = 1900
    set deadband3d_low = 1406
    set deadband3d_high = 1514
    set neutral3d = 1460
    set deadband3d_throttle = 50
    set motor_pwm_rate = 400
    set servo_pwm_rate = 50
    set retarded_arm = 0
    set flaps_speed = 0
    set fixedwing_althold_dir = 1
    set reboot_character = 82
    set serial_baudrate = 115200
    set softserial_baudrate = 9600
    set softserial_1_inverted = 0
    set softserial_2_inverted = 0
    set gps_type = 0
    set gps_baudrate = 0
    set serialrx_type = 0
    set telemetry_provider = 0
    set telemetry_port = 0
    set telemetry_switch = 0
    set vbatscale = 110
    set currentscale = 400
    set currentoffset = 0
    set multiwiicurrentoutput = 0
    set vbatmaxcellvoltage = 43
    set vbatmincellvoltage = 33
    set power_adc_channel = 0
    set align_gyro = 0
    set align_acc = 0
    set align_mag = 0
    set align_board_roll = 0
    set align_board_pitch = 0
    set align_board_yaw = 0
    set yaw_control_direction = 1
    set acc_hardware = 0
    set max_angle_inclination = 500
    set moron_threshold = 32
    set gyro_lpf = 42
    set gyro_cmpf_factor = 600
    set gyro_cmpfm_factor = 250
    set pid_controller = 0
    set deadband = 0
    set yawdeadband = 0
    set alt_hold_throttle_neutral = 40
    set alt_hold_fast_change = 1
    set throttle_correction_value = 0
    set throttle_correction_angle = 800
    set rc_rate = 90
    set rc_expo = 65
    set thr_mid = 50
    set thr_expo = 0
    set roll_pitch_rate = 40
    set yaw_rate = 90
    set tpa_rate = 0
    set tpa_breakpoint = 1500
    set failsafe_delay = 10
    set failsafe_off_delay = 200
    set failsafe_throttle = 1200
    set failsafe_detect_threshold = 985
    set rssi_aux_channel = 0
    set yaw_direction = 1
    set tri_unarmed_servo = 1
    set gimbal_flags = 1
    set acc_lpf_factor = 4
    set accxy_deadband = 40
    set accz_deadband = 40
    set acc_unarmedcal = 1
    set small_angle = 25
    set acc_trim_pitch = -28
    set acc_trim_roll = 80
    set baro_tab_size = 21
    set baro_noise_lpf = 0.600
    set baro_cf_vel = 0.985
    set baro_cf_alt = 0.965
    set mag_declination = 0
    set gps_pos_p = 11
    set gps_pos_i = 0
    set gps_pos_d = 0
    set gps_posr_p = 20
    set gps_posr_i = 8
    set gps_posr_d = 45
    set gps_nav_p = 14
    set gps_nav_i = 20
    set gps_nav_d = 80
    set gps_wp_radius = 200
    set nav_controls_heading = 1
    set nav_speed_min = 100
    set nav_speed_max = 300
    set nav_slew_rate = 30
    set p_pitch = 26
    set i_pitch = 50
    set d_pitch = 20
    set p_roll = 25
    set i_roll = 55
    set d_roll = 20
    set p_yaw = 100
    set i_yaw = 45
    set d_yaw = 0
    set p_alt = 50
    set i_alt = 0
    set d_alt = 0
    set p_level = 90
    set i_level = 10
    set d_level = 100
    set p_vel = 0
    set i_vel = 0
    set d_vel = 0

  17. #97
    markusbs avatar
    Reg.datum
    Jun 2009
    Inlägg
    1 407
    Jobb
    Servicetekniker el/elektronik/maskiner

    Standard

    Ser du några ryck i baseflight från mottagaren och/eller på motorstaplarna om du kör halvgas utan proppar och vinglar lite försiktigt på maskinen?
    Syns det om den är avarmerad på rx?

    Jag hade ju en trasig mottagare... fick frispel på rx-staplarna då och då.
    Lödde om den med hetluften och sedan funkar den kanon.

  18. #98

    Standard

    Jag ska kolla. Jag upptcökte dock ett obehagligt problem med HORIZON, vid två flygningar så började quaden plötsligt att snurra kring YAW-axeln snabbt. Detta händer inte i ANGLE eller ACRO. Detta gör ju att man inte direkt litar på det flygläget nu.

    Sedan så flög modellen betydligt bättre med låga värden i PITCH/ROLL RATE, kändes ibland som att jag tappade kontrollen trots utslag efter att jag hade höjt till 0.45.

  19. #99
    markusbs avatar
    Reg.datum
    Jun 2009
    Inlägg
    1 407
    Jobb
    Servicetekniker el/elektronik/maskiner

    Standard

    Horizon, är det headlock level? Isf kan yawandet kanske bero på kompasstörning?

  20. #100

    Reg.datum
    Oct 2010
    Inlägg
    291
    Jobb
    Vindkraftverkstekniker
    Klubb
    Hemma på gårn

    Standard

    Horizon är väl att den återgår till level när man släpper spakarna. Annars så beter den sig som om man kör i rate/manual

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •