Reklam

 
Resultat 1 till 8 av 8

Ämne: APM Stabilize Flight Mode ej stabilize

  1. #1

    Standard APM Stabilize Flight Mode ej stabilize

    Tjoh!

    Har en DJI F450 med APM 2.6 och samma setup som finns på copter.ardupilot.com. Jag har till och med lagt in de värden som de rekommenderar som bättre utgångsvärden för just DJI F450.

    Vad händer? Jo det går att flyga, men det känns som att själva Stabilize-funktionen är helt avstängd, känns som jag bara styr helt manuellt, beter sig som en vanlig helikopter, dvs släpper jag spakarna så glider den iväg o i backen. Beter sig som en vanlig paddel-heli. !?

    Hade runt 11 satelliter, kompassen stämde, gyrokalibreringen gick bra, motorerna går åt rätt håll, rätt proppar, den flög bra före APM då jag hade KK2, allt sitter fast och i rätt riktning, när jag håller i den och varvar upp lite så reagerar rätt motorer och vill dra tillbaks men det är förstås svårt känna om den vill dra tillräckligt?! och så styr den nog rätt, den går att flyga, men är helt utan stabilize-funktion, fast Stabilize är aktivt enligt Mission Planner.

    Till och med KK2 med stablize inaktiv är bättre, då hålls den i alla fall i det läget man lämnade
    den i, lite som acro. Va sjutton har jag missat?

    /MickeM
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  2. #2

    Reg.datum
    Feb 2013
    Inlägg
    180
    Jobb
    Automation på pappersbruk
    Klubb
    MFK Looping

    Standard

    Citat Ursprungligen postat av Ålänning Visa inlägg

    Vad händer? Jo det går att flyga, men det känns som att själva Stabilize-funktionen är helt avstängd, känns som jag bara styr helt manuellt, beter sig som en vanlig helikopter, dvs släpper jag spakarna så glider den iväg o i backen. Beter sig som en vanlig paddel-heli. !?
    Är det inte så den ska göra då? Den sticker ju åt det håll spakarna vill, och är den inte perfekt trimmad eller det blåser så drar den ju iväg åt nåt håll. Så gör min i alla fall, medan den fungerar perfekt i loiter och hybrid. I hybrid så flyger du j u omkring som vanligt, men släpper du spakarna så stannar den och hovrar på plats. Det är inte det flygläget du är ute efter då?

  3. #3

    Reg.datum
    Apr 2014
    Inlägg
    1 024
    Jobb
    Maskin förare

    Standard

    Radera eprom och flasha om?

  4. #4

    Standard

    Stabilize verkar vara avstängt, så beter den sig. Dvs släpper jag spakarna så kan den fortsätta luta iväg. Den beter sig alltså inte alls som i acro-läge där den håller kvar positionen den va i (ej testat, men ni fattar vad jag menar hur en beter sig, hoppas jag) ;-).

    Min Belt CP jag hade för flera år sen var mycket stabilare. KK2 med self stabilization-läget avstängt är sanslöst mycket stabilare, då kunde man iaf flyga.

    Måste nog köra in allt på nytt. Radera eprom? Räcker det inte med att köra in firmware på nytt och ställa in allt på nytt enligt copter.ardupilot.com?

    Flight mode jag använder är Stabilize, när det funkar så vågar jag testa någon av de andra lägena. Men nu funkar inte stabilize över huvudtaget med stabilize, verkar vara manual 100%-mode nu. Det står ju stabilize i Mission Plannern.

    Hm hm. =)
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  5. #5

    Reg.datum
    May 2013
    Inlägg
    54
    Jobb
    Dr
    Klubb
    Mora MFK

    Standard

    Testa att köra med "default" värden för PID. Mina F450 (tre st, med både små och STORA motorer) flög ok utan att jag ändrat något. Sedan är det bara att köra autotune en kväll när det inte blåser och därefter flyger de perfekt!

  6. #6

    Standard

    Låter som en plan! =) Tack, ska försöka. Jag ändrade ju default-värdena till de som copter.ardupilot.com rekommenderade till en exakt likadan quad-setup som jag har.... kanske är nåt som är olika trots allt (har samma ram, motorer, ESCs, men kanske inte proppar, vikt, 3S/4S).
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  7. #7

    Reg.datum
    Nov 2013
    Inlägg
    118
    Jobb
    Data-Statare
    Klubb
    Uppsala Flygklubbs Modellflygare

    Standard

    Du kan ju göra factory-reset för att återställa alla parametrar. I terminalen tar du setup, sedan t reset om jag mind rätt

  8. #8

    Reg.datum
    Apr 2014
    Inlägg
    1 024
    Jobb
    Maskin förare

    Standard

    Eprom raderar du i terminalen i setup menyn har jag flr mig du kan skriva erase. När du flashar om sparas alla instållningar frpb tidigare. De instäklningar som står på standard värden ändras till de nya om don ändrat default värdet på något mellan versioner.

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •