Reklam

 
Resultat 1 till 20 av 20

Ämne: Hexan vobblade, vad hände?

  1. #1

    Standard Hexan vobblade, vad hände?

    Det var vindstilla och en bekant var ut och flög sin 3DRobotics hexacopter (ca 600 size). Den flög fint och mitt i allt så vobblade den till rätt rejält några sekunder. En kort stund senare så hände samma sak. Lika bra landa... allt funkar fortfarande.

    Den har APM 2.6 med GPS + 3DRobotics svarta originalmotorer (står inget på dem) samt ESCs.

    Flögs i Stabilize-läget.

    Den hade servo-gimbal inkopplad (2 st submicroservon), men den var avaktiverad i Mission Plannern (dvs den hade nog ström antar jag ändå).

    I loggen man får ut från dessa finurliga APMs så kunde man se att strömförbrukningen dubblerades under ca 4 sekunder två ggr när vobblingarna uppstod. I samma veva sjönk spänningen till 13V (4S LiPo).

    Va sjutton hände? Kommer ej på nåt...
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  2. #2

    Standard

    Slirande propellrar?

  3. #3

    Standard

    Det var min ena teori också. Men ska strömmen öka så där mycket då? Alltså 2x ggr totala strömförbrukningen (den hovrade).
    Hörde också att det var rätt så dimmigt/fuktigt vid flygtillfället, inte regn, bara hög luftfuktighet.
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  4. #4

    Reg.datum
    Jan 2012
    Inlägg
    3 898
    Jobb
    AutomationsIngenjör
    Klubb
    ÖdeshögMFK, Tranås Mfk, Mfk Malmen

    Standard

    tror snarare på motorfel, nått lager som börjar ge sig eller något sådant
    ------------------------Skickat från min Texas Instruments TI99-4A ----------------------
    |FPV STUFF|
    |FATSHARK Dominator HD & BASE SD|
    |RiteWing Zephyr II | X * 2X0 Quads Naze32|
    | DJI Inspire 1 |
    |TERMIK OCH HANG |
    |
    Polaris DLG | Twister3 DLG|Arctus DLG|Daidalos 2500|DSF Hangking|
    |FPV4FUN @ Youtube |

  5. #5

    Reg.datum
    Nov 2013
    Inlägg
    118
    Jobb
    Data-Statare
    Klubb
    Uppsala Flygklubbs Modellflygare

    Standard

    Att strömförbrukningen rusar är väl inte så konstigt när motorerna ska varva upp och ner hastigt.

    Vad säger loggarna för pitch/roll/yaw in? Det måste ju vara där fenomenet startar, wobblet är ju en följd av inputsen.


    Du kan ju fråga på diydrones forum också, de är vassa på att ställa diagnoser från loggar, om rätt person intresserar sig för din fråga.

  6. #6

    Standard

    Antalet satelliter var oftast 10 st, ibland 9 och sjönk till 8 när den landats. Så det kan ej ha påverkat. HDop va OK.

    Bifogar bilder nedan... Blå strecket = landat.

    Från loggen såg man att höjden sjunker kraftigt vid varje vobbling, vilket inte är så konstigt.
    Strömmen ändrar vid flygning japp. Men se på de två spikarna. :-o
    Klicka på bilden för en större version. 

Namn:	Current_Altitude.jpg 
Visningar:	67 
Storlek:	22,6 KB 
Id:	49698

    Samt här så ser man att spänningen sjönk drastiskt också.
    Klicka på bilden för en större version. 

Namn:	BatteryVoltage.jpg 
Visningar:	57 
Storlek:	32,2 KB 
Id:	49700

    Och kopplingen mellan ström och spänning.
    Klicka på bilden för en större version. 

Namn:	BatteryVoltage_Current.jpg 
Visningar:	65 
Storlek:	31,0 KB 
Id:	49699

    Hittade att Throttle Out ökade samtidigt vid vobblingen, samma som strömmen ökade. Alltså var det APM som sa åt ESCarna att varva upp motorerna, så att säga?
    Klicka på bilden för en större version. 

Namn:	ThrottleOut_VS_BatteryVoltage.jpg 
Visningar:	66 
Storlek:	28,5 KB 
Id:	49696

    Pitch In + Roll in + Yaw In, se bild. Ser ut som att när pitch in återgått så kommer en spik. Den andra spiken verkar inte ha nån koppling till Pitch in. Kunde ej ha nån kurva till, tre nämnda blev platta då.
    Klicka på bilden för en större version. 

Namn:	RollIn_PitchIn_YawIn.jpg 
Visningar:	65 
Storlek:	32,2 KB 
Id:	49697

    Några av värdena längre ner som man kan logga från (saknar tex GPS VZ som inte finns på den sidan):
    http://copter.ardupilot.com/wiki/dow...ssion-planner/

    Motorerna verkar knattra utan belastning, det gjorde de när jag testade utan proppar. Ska testa med propellrar. Har kollat upp detta tidigare och det lär ska ha vart pga "noload" utan proppar eller så var det för att ESCarna inte har riktigt bra kod, men det skulle inte ha vart nåt att bry sig om, är bara vid uppvarvning. Hm hm. Om de knattrar med proppar, vad är det då?

    Denna hexa har lite nu och då haft lite vobblingsproblem mitt i allt, men inte alla flygningar, bara korta bursts. Hela hexacopter-paketet levererades färdigbyggt och intunat. Allt har även vart tillbaks (till USA alltså) för kontroll och nåt har de gjort, men ingen skillnad alltså. Den har inte många flygtimmar (några ackar) och har inte kraschats, bara landat lite hårdare nån gång så nåt ben farit, men det har vart pga dess beteende.

    Tänker flytta över hela APM-paketet till en DJI F450 och testa. Motorerna är samma som den andra hexacoptern som finns (3DRobotics svarta 880kV). Den funkar bra, men den har andra ESCs (3DRobotics), annars samma grejer.
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  7. #7

    Standard

    Störning från telefonen i fickan?
    RC Åland
    På tok för många flygande saker.

  8. #8

    Reg.datum
    Apr 2014
    Inlägg
    1 024
    Jobb
    Maskin förare

    Standard

    Ström till servon ska förses separat och inte igenom APM. Ifall du inte redan visste.
    Min teori dåligt batteri ena cellen håller på att dö/glappar. Strömmen ökar ju när man går ner från 4s till 3s och den kommer behöva dra på massa extra gas för att kompensera.

    Citat Ursprungligen postat av Ålänning Visa inlägg
    Det var vindstilla och en bekant var ut och flög sin 3DRobotics hexacopter (ca 600 size). Den flög fint och mitt i allt så vobblade den till rätt rejält några sekunder. En kort stund senare så hände samma sak. Lika bra landa... allt funkar fortfarande.

    Den har APM 2.6 med GPS + 3DRobotics svarta originalmotorer (står inget på dem) samt ESCs.

    Flögs i Stabilize-läget.

    Den hade servo-gimbal inkopplad (2 st submicroservon), men den var avaktiverad i Mission Plannern (dvs den hade nog ström antar jag ändå).

    I loggen man får ut från dessa finurliga APMs så kunde man se att strömförbrukningen dubblerades under ca 4 sekunder två ggr när vobblingarna uppstod. I samma veva sjönk spänningen till 13V (4S LiPo).

    Va sjutton hände? Kommer ej på nåt...

  9. #9

    Reg.datum
    Nov 2013
    Inlägg
    118
    Jobb
    Data-Statare
    Klubb
    Uppsala Flygklubbs Modellflygare

    Standard

    Det är inte så enklet att P i regulatorn är satt så högt att den är precis på gränsen till självsvängning? Hade en Tricopter med APM som var "sladdrig" i ramen, och den kunde ibland komma i självsvängning i Yaw. Tyvärr skakade den sönder sig själv i luften innan jag hann trimma in den...

    Har ni autotunat den? Autotune kan ju ibland generera lite väl känsliga PIDdar.

  10. #10

    Standard

    Mr X: Då borde störningen komma fån mobiltelefonen i fickan via sändaren i handen som skulle säga åt multirotorn att sjunka samtidigt som den drar massa mer ström i två bursts på 4 sekunder. Så det går nog bort. Telefonen ringde inte ens, men kunde ända ha uppdaterats. Dessutom är det på andra frekvenser än 2.4GHz.

    eAk: Japp, jag reagerade på det tidigare på dessa hexacoptrar (UBEC-befriade alltså). Det är grejer från 3DRobotics som ett företag (Event38) köpt och byggt till kompletta paket som säljs för tex ortophoto. Dessvärre hade dom nog inte läst bruksanvisningen att APM PM endast ger ström åt APM + RC (i ena kabelhärvan) och inte till servon. Den får nu UBEC. =)

    Dålig ack... Hm, spänningen sjönk bara 1 V från ackens totala (under last) 14 till 13V. Frågan är om nåt drog ström så spänningen sjönk (vanligt förfarande) jämfört med att spänningen sjönk så strömmen steg. Men tillika kan det vara som du säger, dålig cell -> spänningen sjunker -> vobblar -> varvar upp mer med alla motorer -> drar mer ström. Men då borde väl inte hexan sjunka de ca 10 metrarna? Det flögs med Turnigy-ack vid tillfället.

    Det där med att en propeller slirat lite... då varvar den motorn upp mer (drar mer ström) -> spänningen sjunker -> samtidigt som motstående motor varvar ner för att kompensera -> de andra fyra motorerna varvade inte upp (hexan var i Stabilize-läget, ej GPS-positionerat). Kan egentligen inte vara det heller, väl? Eftersom det drog dubbla strömmen och hexan sjönk medans den vobblade. Eller?

    ulwur: P... ska kolla. Kan den då dra dubbelt mer ström + vobbla + sjunka i höjd så mycket? Undras om det finns nåt värde i loggen som säger vad signalen ut till motorerna var... hittade inget sådant första gången jag kikade igenom, borde ju vart 6 st skilda värden.
    För högt värde -> skitsnabb på att slå tillbaks. För lågt värde -> sladdrig och seg samt kommer ej tillbaks till rätt läge lika bra?

    Autotune, nopp! Det har jag aldrig testat. Finns det nån bra länk? =)

    Servona i gimbaln var som sagt inkopplade och drog ström i neutralläge (servona drar 250mA per st vid fullt arbete utan last). De kan inte ha dragit så mycket mer, eftersom han bara flög runt lite försiktigt, det var vindstilla.

    Det var fuktigt... kan det ha påverkat nåt som gjort att strömmen ökade, spänningen sjönk, höjdsjunk o vobbel uppstod?

    En sak till.. när jag skulle strömmäta servona så gjorde jag en adapter och när jag skulle koppla in ett servo i taget för att kolla så var bägge servo-kablar ihoplindande av en metallmärla!!! Isoleringen var skadad på åtminstone en servokabel-ledare. WTF!? Antar att Event38 gjort det när de drog på strumpan och krympslangen. Kan det vara boven? "Liten kortis" mellan jord och plus eller jord och signal (fast jag inte såg nån skada på varken plus eller signal)? Bägge jordledare är skadade ser jag nu.

    Det där med lager i motorer... om ett lager skär sig, då lär det gå trögare och strömmen ökar och spänningen sjunker och hexan vobblar och hexan sjunker för att två motorer "varvats ner". Ingen motor låter nåt speciellt. Kannan glappar upp och ner knappt märkbart (är väl ett visst spel) på 5 av 6, den 6e verkar mest solid och bäst av alla 6 motorer, glappar ej, roterar fint. Ingen motor/axel/propaxeln är vind. Propparna är balanserade.

    Och sen det där med att motorerna knackar... kan det vara dålig batch på ESCar? Eller firmware? De knackar utan propeller alltså. Timing? Men om detta var felet så borde problemet uppstå mycket oftare, inte bara en eller två ggr på några av flygningarna. ?

    Klurigt, men intressant. Just nu vet man ju inte var man ska felsöka. Behålla ramen och slänga allt?! Ska montera hela APM-paketet på en DJI F450 som är aningen billigare att krascha för att testa. Men motorer och ESCs...

    När jag fixade upp en annan Event38 "3DRobotics"-hexacopter så märkte jag ytterligare svagheter hos Event38, de har ej skyddat servo- och matningskablar mot skav mot vassa kanter, så några kablar var skavda så isoleringen var skadad (den multin föll ner från skyn en vacker dag från 35m höjd).
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  11. #11

    Reg.datum
    Apr 2014
    Inlägg
    1 024
    Jobb
    Maskin förare

    Standard

    Men 14 volt. Då är ju batteriet mer eller mindre Slut. Då kan det ju spöka med celler
    Om det är en cell som håller på att dö tycker jag det känns mycket trovärdigt att detta är precis vad som händer. Eller så ligger du med dåligt i och eller p värde. Men det borde ju visa sig tydligare när du ligger runt 16volt

  12. #12

    Standard

    Aha... men en hexacopter som flyger med en 30C 5000mAh 4S 14,8V ack (16,8 fulladdat)... vad har det för spänning vid hovring? 14V = 3,5V per cell vid belastning. Ser man på kurvan ovan som visar spänningen så ser man att spänningen sjunker lite när han hovrar (från 16,2V vid inkopplad ack till 15.7V) när han steg till rätt hög höjd (från 15.7V ner till 14,8V) och sen hovrade runt där en stund (14,8V till 14V) och sen kom dipparna till 13V och sen började han sjunka för att landa (spänningen stiger igen till 15,5V).

    Acken har ju lägre spänning vid belastning, stiger direkt man kopplar ur acken.

    Vet inte vad ESCarna har för cutoff på denna.

    Men som sagt... Turnigy-ack... så man ska ju inte förvänta sig så mycket. =) Nu är det GensAce och ThunderPower som används.
    Jag ska kolla med honom när de andra vobblingarna uppstått.
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  13. #13

    Reg.datum
    Apr 2014
    Inlägg
    1 024
    Jobb
    Maskin förare

    Standard

    För mig känns det som att batteriet har en cell son inte hänger med dom andra om den gör såhär när det är lite ström kvar i batteriet plus flyger som dem ska innan dess. Colintraive tänker jag uppstår för motorerna tappar kraft och den får för hårt jobb att att hålla sig stabil. Motorerna kanske rentav stänger ner sig. Även om det är ett kvalets batteri har man lika lätt sönder dom. Det är inte svårare än att ladda ur det för mycket ett par gånger eller 1 gång Testa ett annat batteri eller blir det alltid såhär?
    Citat Ursprungligen postat av Ålänning Visa inlägg
    Aha... men en hexacopter som flyger med en 30C 5000mAh 4S 14,8V ack (16,8 fulladdat)... vad har det för spänning vid hovring? 14V = 3,5V per cell vid belastning. Ser man på kurvan ovan som visar spänningen så ser man att spänningen sjunker lite när han hovrar (från 16,2V vid inkopplad ack till 15.7V) när han steg till rätt hög höjd (från 15.7V ner till 14,8V) och sen hovrade runt där en stund (14,8V till 14V) och sen kom dipparna till 13V och sen började han sjunka för att landa (spänningen stiger igen till 15,5V).

    Acken har ju lägre spänning vid belastning, stiger direkt man kopplar ur acken.

    Vet inte vad ESCarna har för cutoff på denna.

    Men som sagt... Turnigy-ack... så man ska ju inte förvänta sig så mycket. =) Nu är det GensAce och ThunderPower som används.
    Jag ska kolla med honom när de andra vobblingarna uppstått.

  14. #14

    Standard

    Jag kollade fler loggar från samma APM som suttit i samma multirotor hela hösten. Den har flugits bara ca 7 tillfällen.... men 2 av loggarna innehöll samma spik. Skumt... jag bad ägaren märka sina ackar och föra flyglogg i fortsättningen. =)
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  15. #15

    Standard

    Igår hittade vi nog vilken ack det var som ställt till dessa vobbelproblem.

    Det flögs en octocopter med gimbal och Canon digitalkamera... mitt i allt så kom det två spikar och sen slogs motorerna av och octan vände upp och ner i luften och ramlade i nätt hastighet rakt ner i en åker från 130m höjd. Vad gick slut? 4 proppar. :-D Det ni!!! (ja och nån spacer för APM-plattorna). Helt otroligt. Kameran fick en liten spricka. Gimbaln hoppade ur. Det sa ej Smack eller Crack eller nåt sånt, utan bara Boff. Nu loggas varenda flygning, inklusive de med octan. Tanken finns, att det är en enda ack som skapat alla problem som funnits senaste året. Och är det så, så är det väl bara att konstatera att Zippy inte är världsbäst... ;-D Doh!
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  16. #16

    Reg.datum
    Apr 2014
    Inlägg
    1 024
    Jobb
    Maskin förare

    Standard

    Citat Ursprungligen postat av Ålänning Visa inlägg
    Igår hittade vi nog vilken ack det var som ställt till dessa vobbelproblem.

    Det flögs en octocopter med gimbal och Canon digitalkamera... mitt i allt så kom det två spikar och sen slogs motorerna av och octan vände upp och ner i luften och ramlade i nätt hastighet rakt ner i en åker från 130m höjd. Vad gick slut? 4 proppar. :-D Det ni!!! (ja och nån spacer för APM-plattorna). Helt otroligt. Kameran fick en liten spricka. Gimbaln hoppade ur. Det sa ej Smack eller Crack eller nåt sånt, utan bara Boff. Nu loggas varenda flygning, inklusive de med octan. Tanken finns, att det är en enda ack som skapat alla problem som funnits senaste året. Och är det så, så är det väl bara att konstatera att Zippy inte är världsbäst... ;-D Doh!
    Dom sväller rätt snabbt men det gör mina gens Ace till bilarna också. Om man inte håller dom förvaringsladdade och aldrig flyger under 40%

    Jag kör dubbla batterier sedan ett år just pågen av den lilla extra säkerheten om en cell dör.

  17. #17
    Kenneth Es avatar
    Reg.datum
    Oct 2006
    Inlägg
    3 208
    Jobb
    Glidare
    Klubb
    IGG SYD

    Standard

    Vad drar koptarna i ström, ni snackar spänning? Begrep inte mycket på loggarna, rena hyroglyferna.

    Spänningen använder man för att hitta fel, strömmen för att avgöra vad som är fel. 4S5000 tål inte mycket ström innan de tappar spänning, gör en belstningstest på batteriet.
    Ken
    DS-24 operatör.
    Hatar min dator, men tillbringar ändå 10 timmar om dagen med den.
    Älskar mina 30s med Stinger 400 size när den går som bäst.
    FPV is das Shit! avstånd 27km med TechPod, höjd 2.7km med X8, Dragonlink och 1.3VTx.

  18. #18

    Reg.datum
    Apr 2014
    Inlägg
    1 024
    Jobb
    Maskin förare

    Standard

    ja har du laddat ur ström ur batteriet så minskar du batteriets spänning krånglar en cell så ligger den ju lägre än de andra när du kopplar in den i din laddare eller multimeter eller vad du nu vill mäta upp dina celler med.

    Så ett enkelt sätt som du säger är att köra på bänken och maxxa några motorer på accen och se vad som händer med dina celler.

    Citat Ursprungligen postat av Kenneth E Visa inlägg
    Vad drar koptarna i ström, ni snackar spänning? Begrep inte mycket på loggarna, rena hyroglyferna.

    Spänningen använder man för att hitta fel, strömmen för att avgöra vad som är fel. 4S5000 tål inte mycket ström innan de tappar spänning, gör en belstningstest på batteriet.
    Ken

  19. #19

    Standard

    GensAce-ackarna är i toppskick och aldrig varit med i nån krasch.
    Det är fulingarna Turnigy och Zippy som varit med om allt.
    Zippy-ackarna är noll svullna (ena hade tydligen en cell farit på så den är slängd).
    GensAce sköts om, de andra har haft ett hårdare liv tills ägaren fick veta hur man skulle hantera dem.
    Flera av dem (Turnigy o Zippy) har vart under 40%.
    Dubbla ackar parallellt skulle ju va nåt... får kolla om de orkar lyfta nuvarande ackar.
    Hur märker du om en cell har dött om du kör två ackar?
    Hur mycket de drar, hm... nu är det så många multicoptrar jag haft att göra med så jag har tappat kollen på det.
    Det loggas, men Mission Plannern presenterar det så konstigt med en skala på 1000-6000 tex.
    Loggarna tycker jag säger en hel del när man väl hittat rätt värden att se på och jämföra mot flygningen. =)
    Men om man får ut en exakt orsak till problemet, det vete sjutton om man lyckas med snabbt.
    Om en multirotor drar en massa ström så kommer acken snart att tappa orken (spänningen sjunker?).
    Hur ska jag belastningstesta? Jag tog fram 6 st av dessa ackar. I helgen tänkte jag testa binda fast multirotorn och varva lite och se vad de drar då och sedan se loggen om nån sån där spik dök upp igen.
    Dessa strömspikar (som är dubbelt högre ström än vid flygning i blåst) så har bara uppkommit i loggarna där det varit problem med flygningen eller då krasch uppstått.
    Jag mätte acken som var med i senaste krasch (ej laddat/storageladdat efter krasch).... 3,98V på varje cell och totalt 9mV skillnad. Rätt bra trots allt. Ska testa mer i helgen.
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  20. #20

    Reg.datum
    Apr 2014
    Inlägg
    1 024
    Jobb
    Maskin förare

    Standard

    du kan skruva fast några hämska motorer med stora proppar på och köra med servo testare.
    sammtidigt mäta balanskontakten för att se om dom droppar(ex lipo alarm med display funkar).

    jag brukar märka att mina är påväg att bli kassa av att dom sväller upp då köper jag nytt. Jag märker ju rätt tydligt på hur min multi presterar också om accarna börjar bli kass.

    Men jag laddar ofta ur mina för mycket och får köpa nya efter kanske ca 5timmar flygtid eller något sådant.

    Misstänker jag något så kollar jag extra noga vad cellerna ligger på för spänning har någon dragit iväg ovanligt mycket så vet jag direkt att den är kass och slutar använda den.

    Citat Ursprungligen postat av Ålänning Visa inlägg
    GensAce-ackarna är i toppskick och aldrig varit med i nån krasch.
    Det är fulingarna Turnigy och Zippy som varit med om allt.
    Zippy-ackarna är noll svullna (ena hade tydligen en cell farit på så den är slängd).
    GensAce sköts om, de andra har haft ett hårdare liv tills ägaren fick veta hur man skulle hantera dem.
    Flera av dem (Turnigy o Zippy) har vart under 40%.
    Dubbla ackar parallellt skulle ju va nåt... får kolla om de orkar lyfta nuvarande ackar.
    Hur märker du om en cell har dött om du kör två ackar?
    Hur mycket de drar, hm... nu är det så många multicoptrar jag haft att göra med så jag har tappat kollen på det.
    Det loggas, men Mission Plannern presenterar det så konstigt med en skala på 1000-6000 tex.
    Loggarna tycker jag säger en hel del när man väl hittat rätt värden att se på och jämföra mot flygningen. =)
    Men om man får ut en exakt orsak till problemet, det vete sjutton om man lyckas med snabbt.
    Om en multirotor drar en massa ström så kommer acken snart att tappa orken (spänningen sjunker?).
    Hur ska jag belastningstesta? Jag tog fram 6 st av dessa ackar. I helgen tänkte jag testa binda fast multirotorn och varva lite och se vad de drar då och sedan se loggen om nån sån där spik dök upp igen.
    Dessa strömspikar (som är dubbelt högre ström än vid flygning i blåst) så har bara uppkommit i loggarna där det varit problem med flygningen eller då krasch uppstått.
    Jag mätte acken som var med i senaste krasch (ej laddat/storageladdat efter krasch).... 3,98V på varje cell och totalt 9mV skillnad. Rätt bra trots allt. Ska testa mer i helgen.

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •