Reklam

 
Sidan 1 av 2 12 SistaSista
Resultat 1 till 20 av 30

Ämne: Turnigy x9 firmware flash.. Usbasp.. Drivers..

  1. #1

    Standard Turnigy x9 firmware flash.. Usbasp.. Drivers..

    Hej alla..
    Första posten på forumet och tror jag läst och testat alla möjliga vis och OS för att installera mina två olika
    USBASP.. Men helt utan lycka..

    Lyckas inte i windows 7, 8, 8.1 eller 10...

    Försökt installera ( win XP ).. Men föör ny dator för det.. haha..
    Men Finns det någon som bor i Nordvästra Skåne eller så som kanske kan hjälpa till?
    Får jag iofs bara rätt på någon av mina två usbasp så kan jag själva flasha biosen men dom ska alltid
    strula..


    PeaCe !

  2. #2

    Standard

    Vad får du för felmeddelande, eller vad händer?

  3. #3

    Standard

    Digital driver signing???


    http://www.fischl.de/usbasp/


    https://openchrysalis.wordpress.com/...n-windows-8-1/


    Jag installerade det på min dator i veckan utan problem (win 8.1)
    UndCon.com = Under Construction == A constant evolving state of mind...

  4. #4

    Standard

    Enligt Enhetshanteraren är den installerad men när jag försöker läsa eller skriva så får jag "Cannot set sck Period"
    Men med min andra Usbasp så installeras den som en usb input device och går ej att byta till andra drivrutiner på den..
    ATM kör jag windows 7 samt (win 10 tech)..


    Klicka på bilden för en större version. 

Namn:	usbasp.png 
Visningar:	60 
Storlek:	115,7 KB 
Id:	52057Klicka på bilden för en större version. 

Namn:	usbasp2.png 
Visningar:	157 
Storlek:	85,8 KB 
Id:	52058

  5. #5

    Standard

    tack, men körs redan precis på samma vis..
    Men ser att när jag försöker skriva eller läsa så blinkar det iaf till på min usbasp så verkar vara rätt installerad nu..
    Kanske..
    Men fortfarande får jag inte den till att programera..

  6. #6
    dvogonens avatar
    Reg.datum
    Jul 2012
    Inlägg
    493
    Jobb
    Programutvecklare
    Klubb
    Tullinge MF

    Standard

    Citat Ursprungligen postat av athlech Visa inlägg
    Enligt Enhetshanteraren är den installerad men när jag försöker läsa eller skriva så får jag "Cannot set sck Period"
    Men med min andra Usbasp så installeras den som en usb input device och går ej att byta till andra drivrutiner på den..
    ATM kör jag windows 7 samt (win 10 tech)..
    Den första goda nyheten är att drivrutinen för USBASPn verkar fungera. Om den inte hade fungerat så hade du AVRDUDE inte startat upp. Du hade istället fått ett meddelande om att ingen programmeringsdevice kunde hittas.

    Den andra goda nyheten är att det första felmeddelandet "Cannot set sck period" är normalt. Det betyder bara att det inte går att ställa in klockfrekvensen på din USBASP. Den är redan inställt på ett vettigt värde så du kan bortse från den varningen.

    Men sedan kommer de dåliga nyheterna. Felmeddelandena "Target does not anwer" och "Device signature=0x000000" tyder på att det inte finns korrekt kontakt mellan din USBASP och den Atmel-processor som sitter i radion. Jag har för mig att du får exakt dessa meddelanden om du försöker programmera utan att kabeln från USBASPn till radion ansluten. Det är dock ett tag sedan jag höll på med 9x, så mitt minne kan ha fel.

    Kolla först alla kablar och lödningar. Om du inte hittar några avbrott får du kolla continuity mellan kontakten på USBASPn och de processorben som används för programmering. Här finns databladet för processorn: http://www.atmel.com/Images/Atmel-24..._datasheet.pdf

    Om du inte heller nu hittar några fel kan du börja oroa dig :-)

  7. #7

    Standard

    Har nu suttit och testat så det är kontakt mellan processor pinnarna till rätt på usbasp som jag gjort innan också..
    Men inget fel där nu heller tyvärr.. :/
    Men när jag mäter på usbasp:n så lämnar den 5v på rätt pinnar när den är kopplad i datorn bara..
    Men när jag kopplar in med processorn så får jag bara 3.2v ..

    Fel på min usbasp ?

    ger snart upp och köper en ny kontroll.. :/

  8. #8
    dvogonens avatar
    Reg.datum
    Jul 2012
    Inlägg
    493
    Jobb
    Programutvecklare
    Klubb
    Tullinge MF

    Standard

    Ge inte upp. Ju mer problem man möter, desto större tillfredsställelse när man lyckas lösa dem. USBASPer kan vara rejält jävliga att få att funka, men det brukar gå om man är enträgen. När du väl lyckas programmera en gång så kommer det att fortsätta att fungera utan problem.

    Det är inte OK att spänningen sjunker till 3.2 volt vid programmeringen av Armel64. Men att den gör det behöver inte betyda att din programmerare är trasig. En del versioner av USBASP har en bygling där man kan välja mellan 3.3 volt och 5 volts spänning. Man måste välja 5v. Andra varianter saknar bygling och inställningen görs genom att man kortsluter två lödpukter.

    Om spänningsvalet är rätt (och det tror jag det är eftersom du mäter 5v obelastat) så kan problemet vara att det sitter ett motståndsnät mellan processorn på USBASPn och kontakten. Ibland sitter det istället diskreta resistorer på signalledningarna. Motstånden brukar vara på 100-300 Ohm. Tyvärr ställer de till problem i den här applikationen. Lösningen är enkel: man plockar bort motstånden och lägger lödbryggor mellan lödpunkterna. Du hittar information på nätet om det om du söker på något i stil med "9x usbasp resistance".

    Lycka till och ge inte upp hoppet.

  9. #9

    Standard

    Nä men när man lekt runder med detta i snart 2 månader så börjar jag bli riktigt trött på d..
    Läst och testat hur mycket som nu..

    Har 0.2 Ohm mellan mosi o miso från atmega8a processorn till pinout på usbasp..
    Så borde inte vara det..

    Har även provat att koppla bort allt som går från "moderkortet" i sändaren men ingen skillnad där heller..
    Läst o testat " http://9xrprogrammer.com/index.php/l...roubleshooting "
    Guiden också men tyvärr utan lycka.. :/

    Men snällt du försöker få upp mitt hopp igen..

  10. #10
    dvogonens avatar
    Reg.datum
    Jul 2012
    Inlägg
    493
    Jobb
    Programutvecklare
    Klubb
    Tullinge MF

    Standard

    Men något hårdvarustrul verkar det vara. Spänningen får inte sjunka ned till 3.2 volt vid programmering. Jag har för mig att 4.5 är OK, men inte lägre.

  11. #11

    Standard

    kan jag ansluta 5v vid sidan om då tro?
    Har en FTDI232 som jag vet fungerar.. kanske köra 5v från den ist?

  12. #12

    Standard

    Jag kommer inte ens ihåg hur jag gjorde Min programmerare sitter i min 9X
    UndCon.com = Under Construction == A constant evolving state of mind...

  13. #13

    Standard

    Om jag minns rätt måste man starta radion med det egna batteriet _efter_ att du anslutit USBASP till radion och datorn för att kunna programmera.
    Och efter avslutad programmering stänger du först av radion och sen plockar ur USBASP.
    / Jonas

  14. #14

    Standard

    Läste precis mina egna kommentarer i tråden jag länkade till - slå EJ på strömmen i radion...
    UndCon.com = Under Construction == A constant evolving state of mind...

  15. #15

    Standard

    Jag har skruvat ihop hela radion nu med sladden ut så allt är ihop kopplat..
    Men eftersom jag gjort telementri modden samtidigt får jag eeprom error i displayen, antar jag iaf..
    Men vilket som borde jag kunna flasha den.. Fått ritningen på min USBASP nu så ska kolla så inte något
    är omkastat eller så.. Men satt min jord på nr 4 men när jag mätte till 3.2 men efter lite läsande till så är det nr 10
    som är nya standard pin för jord o där får jag 5v hela tiden..
    Klicka på bilden för en större version. 

Namn:	IMG_1043.jpg 
Visningar:	133 
Storlek:	123,3 KB 
Id:	52086

    Klicka på bilden för en större version. 

Namn:	IMG_20150429_184346.jpg 
Visningar:	45 
Storlek:	141,1 KB 
Id:	52087Dock vet jag inte vad det är för modd tidigare ägare gjort.. Hittar inte någon som gjort samma.. Så kanske har med det att göra?

  16. #16

    Standard

    På de grövre oranga/gula kablarna ser det ut att sitta en voltregulator som är fastlödd. Dessa brukar man montera kondensatorer på för att stabilisera utgången.

    Och vad gör den ? 7805 eller 7806?

    5 alt 6 volt ut...
    UndCon.com = Under Construction == A constant evolving state of mind...

  17. #17

    Standard

    Jag har för mig att det finns två olika layouter på processorkoret på TGY 9X, det kan inte vara så att du använt fel schema när du anslutit kablarna till USBASP?
    Jämför dessa två bilder och notera att SCK är inlödda på olika ställen.
    http://th9x.googlecode.com/svn/wiki/....png?width=600
    http://www.linushelgesson.se/wp-cont...ion-points.jpg
    /Jonas
    Bifogade miniatyrer Bifogade miniatyrer Klicka på bilden för en större version. 

Namn:	Connection-points.jpg 
Visningar:	52 
Storlek:	167,0 KB 
Id:	52088  

  18. #18
    dvogonens avatar
    Reg.datum
    Jul 2012
    Inlägg
    493
    Jobb
    Programutvecklare
    Klubb
    Tullinge MF

    Standard

    Om man tittar noga på bilderna för de utförda moddarna så kan man se att kretskortet är av typ v2. V1-korten utgick ur produktion för ett antal år sedan straxt innan 9x blev populär. De är inte vanliga.

    Vad jag kan se så sitter kablarna där man kan förvänta sig på ett v2-kort.

    Vad jag förstår så har radion flashats med framgång tidigare. Stämmer det?

  19. #19

    Standard

    Ja jag är 99% säker på att det är ett v2 o att alla sitter rätt så jag räknat och testat mäta så det inte råkat lödda över eller så.. men ingen kontakt mellan några alls..

    Andra modden som tidigare ägare gjort antar jag bara har med batteriet att göra.. ( LiFe batteri och inte varit något problem innan, därför inte rört det alls..)

    Var orginal förrutom frsky modul och annat batteri.. Men telemetrin var inte kopplad och det har jag kopplat samtidigt nu..
    Ska man lödda bort det för att garantera att det inte är det.. ?

  20. #20

    Standard

    Nu har jag äntligen fått rätt på det..
    Beställde en ny ASP som är "9xr programmer"
    Kopplade in och vipps så fungerade det..

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •