Reklam

 
Sidan 1 av 2 12 SistaSista
Resultat 1 till 20 av 30

Ämne: NAZA Gain's för 680 Hexacopter á 3.3 kg

  1. #1

    Standard NAZA Gain's för 680 Hexacopter á 3.3 kg

    Hej!
    Efter en ganska tråkig krasch för snart ett halvår sedan har jag tagit tag i denna hobby igen och fixat till min hexacopter.

    För att inte göra en återupprepning undrar jag om det finns någon som kör en hexaopter runt 680 storlek med Naza v2 controller och vill dela med sig av sina inställningar.

    Min crash orsakades av att helikoptern kom i självsvängning och helt enkelt pendlade fram och tillbaka tills den flippade runt och landade väldigt fort och högst oväntat. Då hade jag dessa värden:
    Basic: 170, 170, 150, 140
    Attitude: 170, 170.


    Efter reparationer gjorde jag precis en testhovring i GPS läge med:
    Basic: 150, 150, 150, 120
    Attitude: 150, 150.

    ..och det verkade funka (med det gjorde det på 170 med), men innan jag provar något mer avancerat vill jag gärna veta vad ni andra med liknande helikoptrar har för värden?Heli: Arris 680 ram (typ samma som FY680 eller 690..)
    Motorer: 6x KV380 (MN3508-29) T-Motors
    Proppar: 1355 kolfiber
    Batteri: 6S 5000mAh

  2. #2

    Standard

    Med för höga värden ska den i alla fall inte vara så degig. Dvs med för låga värden så ökar risken att flippa. Har inte DJI nån smart guide för hur man ska testa fram dessa gains med att börja högt, minska tills det slutar "vibrera" eller nåt, minns ej och borde zzz.

    När du hovrar på stället, gör du det vid halvgas? Om du gör det under det så roterar nog inte propparna tillräckligt. Då har multis för mig blivit lite orediga och inte alls stabila.
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  3. #3
    Stiffes avatar
    Reg.datum
    Jan 2012
    Inlägg
    999
    Jobb
    Malmö
    Klubb
    Rcff

    Standard

    Tror också på att du haft för lite snurr på propparna så den inte kan hinner kompensera tillräckligt , var det ström kvar i liposen så det inte var strömproblem ?? har aldrig haft pendlingar som du beskriver trots tester med väldigt höga gains och för lite på både Naza och WKM , har själv haft hexor i den storleken och ungefär samma inställningar som du hade när du ramlade ner utan problem
    Bor i Malmö
    Dji S 900 - Z15 Gh 3 , Futaba 8 S , Phantom 2 - Zenmuse H3 3D - Phantom 3 PRO https://vimeo.com/user9839897

  4. #4

    Standard

    Med för låga gains och med tyngdpunkten under propellercentrum så kan det pendla rätt friskt, eller slå över. Med rätt setup vill man att motorerna ska få arbeta mitt i sitt arbetsintervall så det finns spel åt bägge håll för uppvarvning och nedvarvning, så hastigt det går. Här är jag lite novis med skillnaden på att flyga med 50Hz, 400Hz och 600Hz ESCar. Ju högre frekvens, desto stabilare. 50Hz är vanligast på flyg.
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  5. #5

    Standard

    Tack för tipsen, om det hjälper kan ni se krashen här: http://youtu.be/f4mfIJ2_Wbk?t=
    Sker vid 5 min 30 sek

    Gör fortfarande ont att titta på.

    Det jag gjorde var fullt utslag i en riktning, sedan släppte jag kontrollerna helt för att visa "hur stabil den var".

    Batteriet var knappt använt när jag skulle ladda det igen.
    Senast redigerat av SwedenByAir den 2015-08-17 klockan 16:24.

  6. #6
    Stiffes avatar
    Reg.datum
    Jan 2012
    Inlägg
    999
    Jobb
    Malmö
    Klubb
    Rcff

    Standard

    Den var ju hur stabil som helst tills det gick åt skogen ?? lät ju inte som du hade lågt varvtal , nu vet jag inte om du kände på det , men var motorer och Esc normalvarma , du har inte underdimensionerade Esc så dom ballade ur ?

    Vill inte vara petig men det är kanske inte att rekommendera att provflyga mitt i ett bostadsområde , hade den ballat ur på annat sätt hade den flugit rakt genom en ruta eller ännu värre på någon människa
    Bor i Malmö
    Dji S 900 - Z15 Gh 3 , Futaba 8 S , Phantom 2 - Zenmuse H3 3D - Phantom 3 PRO https://vimeo.com/user9839897

  7. #7

    Standard

    Hm, för låga gains? Typ: Nu lutar det -> kompenserar -> lutade förbi mittläget och märker att det gick förbi, reagerar segt och kompenserar tillbaks -> och så går det över mittläget igen men ännu mer och den hinner inte kompensera och kompenserar ÄNNU mer och så blir det värre och värre. Tänker jag rätt då? Frågan är vilket värde som är för lågt, kanske bägge?

    Stabil va den, men den flögs lugnt och det är en hexa.

    För högt värde, då borde den ha reagerat fortare och nästan slungat tillbaks den till rätt ställe, som om den drogs tillbaks av en riktigt kraftig fjäder, nästan så man tror att den ska gå sönder av kraften den vill tillbaks. =) Höger gains än det så börjar den nästan vibrera. Lite så har jag känslan när jag pysslat med hexacoptrar och Naza/APM.

    Men det är så uppenbart fel som händer, så någon annan borde kunna se direkt vad som är fel. Jag blir bara osäker och tänker på hur jag tänker när jag har problem med mina.

    Jag tycket det var nåt som pep/gnisslade närmare slutet. Satt propparna fast? Speciellt när du bytte riktning runt giraxeln.
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  8. #8

    Standard

    Citat Ursprungligen postat av Stiffe Visa inlägg
    Vill inte vara petig men det är kanske inte att rekommendera att provflyga mitt i ett bostadsområde , hade den ballat ur på annat sätt hade den flugit rakt genom en ruta eller ännu värre på någon människa
    Nej du har helt rätt. Det var dumt av mig och kommer inte hända igen. Det var ingen annan ute då och suget för att se om skiten funkade efter 4 månaders byggande tog överhanden.

    Citat Ursprungligen postat av Stiffe Visa inlägg
    Den var ju hur stabil som helst tills det gick åt skogen ?? lät ju inte som du hade lågt varvtal , nu vet jag inte om du kände på det , men var motorer och Esc normalvarma , du har inte underdimensionerade Esc så dom ballade ur ?
    Inget var varmt. ESCarna är på 30A och borde vara mer än vad som krävs. Motorerna drar som mest 12A med 1550 proppar vid 6S (jag kör 1355), så jag borde ha mer än dubbla.
    Källa: http://www.quadcopters.co.uk/ekmps/s...8-29-specs.jpg


    Citat Ursprungligen postat av Ålänning Visa inlägg
    Hm, för låga gains? Typ: Nu lutar det -> kompenserar -> lutade förbi mittläget och märker att det gick förbi, reagerar segt och kompenserar tillbaks -> och så går det över mittläget igen men ännu mer och den hinner inte kompensera och kompenserar ÄNNU mer och så blir det värre och värre. Tänker jag rätt då? Frågan är vilket värde som är för lågt, kanske bägge?

    För högt värde, då borde den ha reagerat fortare och nästan slungat tillbaks den till rätt ställe, som om den drogs tillbaks av en riktigt kraftig fjäder, nästan så man tror att den ska gå sönder av kraften den vill tillbaks. =) Höger gains än det så börjar den nästan vibrera. Lite så har jag känslan när jag pysslat med hexacoptrar och Naza/APM.

    Men det är så uppenbart fel som händer, så någon annan borde kunna se direkt vad som är fel. Jag blir bara osäker och tänker på hur jag tänker när jag har problem med mina.

    Jag tycket det var nåt som pep/gnisslade närmare slutet. Satt propparna fast? Speciellt när du bytte riktning runt giraxeln.
    Ja det var ju inte direkt subtilt började bara gunga mer o mer och mitt vevande på radion hade noll effekt.

    Jag har inte tänkt på något pipande/gnisslande, ska kolla igen, men jag kan nästan lova att propparna satt på hårt, dubbelkollade o trippelkollade allt några gånger om innan jag startade. Inget verkar iaf blocka motorerna när jag snurrar på den nu, och den flög igår igen hur fint som helst (hovrade enbart 2m ovanför marken)

    Min fundering om vad som hände kan gå åt båda hållen.. Antingen överkompenserade den mer o mer tills den var upp o ner, eller så klarade den inte av att kompensera fort nog och fick aldrig balans.
    Senast redigerat av SwedenByAir den 2015-08-17 klockan 19:28.

  9. #9

    Standard

    På denna video har någon annan nästan exakt samma setup som jag: https://www.youtube.com/watch?v=uMzGobI6lUQ
    och enligt kommentarer på videon: "when I had the Naza V2... 130 130 130 150 Basic 110 110"

    Vilket går lite emot att gainsen är för låga...

  10. #10

    Standard

    Den kompenserade nog, men inte tillräckligt snabbt skulle jag tycka och den överkompenserade mer och mer.
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  11. #11

    Standard

    Vad använder du för ESC?

    Vissa äldre flygreglage sköter sig inte så bra.

    https://www.youtube.com/watch?v=FLKIOPbXVnM

  12. #12

    Standard

    Citat Ursprungligen postat av Jorgen Visa inlägg
    Vad använder du för ESC?
    Vissa äldre flygreglage sköter sig inte så bra.
    https://www.youtube.com/watch?v=FLKIOPbXVnM
    6x Platinum 30A Pro OPTO ESC (http://www.hobbywing.com/product_show.asp?id=285)

    Citat Ursprungligen postat av Ålänning Visa inlägg
    Den kompenserade nog, men inte tillräckligt snabbt skulle jag tycka och den överkompenserade mer och mer.
    Hmm, så du tror helt enkelt att jag ska ha högre värden?

  13. #13

    Standard

    ESCarna.. "Aircraft system"? Är det alltså bara 50Hz ESCar? Borde väl helst vara mycket mer, typ runt 400? Eller vad Jorgen?

    Högre värden... Minns inte hur det var med Naza nu, men det finns väl både P-del och I-del? D-delen nämns väl inte? P-delen (proportionella) ska dra tillbaks "till dit där den var" på ett försök, men kommer sällan exakt till rätt ställe, där kommer I-delen (integrerande) in och finjusterar det sista. Är P för högt så går den förbi. Är P för lågt så når den knappt fram. I-delen ska vara så ställd att den finjusterar det sista helst perfekt med en gång, är det för högt värde går även den förbi, är det allt för högt så går det på tok för långt förbi. Är I-delen för låg så har jag för mig att det svänger X antal ggr tills det är på rätt. Så tycker jag mig minnas att P- och I-delen fungerar i en PID-regulator (same same). Brukar man inte sätta I-delen till 0 för att först justera in P-delen så bra som möjligt, så att man inte har P-delen åt fanders medans man försöker rätta felet med I-delen. Obs, jag är rätt n00b på Naza. Jag vet att det finns ett sätt att ställa in Naza PIDs steg för steg på den säkra sidan. Och jag vet att det finns andra här som har bättre koll på det tillvägagångssättet än mig. Man testar helt enkelt en sak i taget, men ska ha värdena på den säkra sidan som utgångspunkt. Att höja bägge värden kanske inte är det du ska börja med. Skulle du ha frågat när jag höll på med Nazan på min Disco så skulle jag haft bättre koll. :-)
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  14. #14

    Standard

    Citat Ursprungligen postat av Ålänning Visa inlägg
    ESCarna.. "Aircraft system"? Är det alltså bara 50Hz ESCar? Borde väl helst vara mycket mer, typ runt 400? Eller vad Jorgen?
    Dessa två saker står i detaljerna:
    1.4 Refresh rate of the throttle signal: 50Hz to 432Hz.
    2.2 Optimized for multi-rotor aircraft.

    Jag vill tro att den ställer in sig efter vad kontrollern klarar av att leverera,, så trycker nazan ut 400Mhz tar den emot det...

    Tycker överlag det är väldigt dålig info om hur man ska ställa in NAZA'n och vad man ska göra för att få den att prestera på topp. Haft Multiwii innan och då var det mycket tydligare vad det var man ställde in egentligen (även om den hade sina egna problem i andra områden).

    Får försöka justera värdena en åt gången och se om något händer.

  15. #15

    Standard

    Har för mig att det står i Naza-manualen att det måste vara 400Hz ESCs. Jag testade 50Hz PowerHD 20A flyg-ESCs mot Nazan och inte funkade det.
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  16. #16

    Standard

    Det där borde vara en bra ESC, fungerar i alla fall perfekt på min Discovery.

    Kommer alla reglagen från samma batch? Olika mjukvaror kan eventuellt ställa till det lite om man tex kompletterat ett set för en quad med två extra reglage i efterhand.

    Är de kalibrerade?

    Normal PID tuning verkar inte gå att göra på en Naza då inga av de vanliga PID värdena är tillgängliga. Men beteendet påminner om integral windup, integrator windup eller helt enkelt "I" windup. Det brukar bero på att hårdvaran som man försöker reglera reagerar för långsamt i förhållande PID loopen. Det vi kan ta med oss från det är väl att försöka hitta något som reagerar långsamt.

    Har du ställt tomgångsvarvet väldigt lågt?

    Är propellrarna väldigt tunga?

    Har du råkat slå på bromsen på ett eller flera reglage?

    Hur är det med vibrationer?

    Och det är väl en Naza och inte en Wokong? Vissa kombinationer av Wokong IMU och GPS verkar vilja gå i backen på det sättet så ofta de kan.

  17. #17
    Stiffes avatar
    Reg.datum
    Jan 2012
    Inlägg
    999
    Jobb
    Malmö
    Klubb
    Rcff

    Standard

    Och det är väl en Naza och inte en Wokong? Vissa kombinationer av Wokong IMU och GPS verkar vilja gå i backen på det sättet så ofta de kan.
    Vet jag inte var du fått det ifrån , har flugit WKM sen de kom ut utan problem , det fanns en batch GPS som DJI kostnadsfritt bytte ut men det är många år sen om det är det du hört ?
    Bor i Malmö
    Dji S 900 - Z15 Gh 3 , Futaba 8 S , Phantom 2 - Zenmuse H3 3D - Phantom 3 PRO https://vimeo.com/user9839897

  18. #18

    Standard

    Citat Ursprungligen postat av Stiffe Visa inlägg
    Vet jag inte var du fått det ifrån , har flugit WKM sen de kom ut utan problem , det fanns en batch GPS som DJI kostnadsfritt bytte ut men det är många år sen om det är det du hört ?
    Jo, precis dem. Det kommer upp ganska mycket om dem när man börjar söka på flippande DJI produkter. Att man kunde få GPSen utbytt gratis betyder ju inte att alla är inbytta så jag tyckte att det var lämpligt att fråga så att det inte var en WKM

  19. #19

    Standard

    Citat Ursprungligen postat av Jorgen Visa inlägg
    Är de kalibrerade?
    Har använt escprogrammeringskortet för att stänga av cut off, inget annat.

    Citat Ursprungligen postat av Jorgen Visa inlägg
    Har du ställt tomgångsvarvet väldigt lågt?
    Nej, det är på "Normal"

    Citat Ursprungligen postat av Jorgen Visa inlägg
    Är propellrarna väldigt tunga?
    De är vanliga kolfiberproppar från HobbyWing. 14g st (http://www.hobby-wing.com/tarot-1355...er-tl2829.html)

    Citat Ursprungligen postat av Jorgen Visa inlägg
    Har du råkat slå på bromsen på ett eller flera reglage?
    Har ingen broms?

    Citat Ursprungligen postat av Jorgen Visa inlägg
    Hur är det med vibrationer?
    Alla proppar är välbalanserade och verkar inte vara särskilt mycket när man mäter med telefon och accelerometer app

    Citat Ursprungligen postat av Jorgen Visa inlägg
    Och det är väl en Naza och inte en Wokong? Vissa kombinationer av Wokong IMU och GPS verkar vilja gå i backen på det sättet så ofta de kan.
    Det är en Naza V2, köpt för ca 1 år sedan.



    Sedan krashen har jag hängt på en burk med 700g grus under helin för att flytta COG och för att simulera kamerahuset som kommer vara där sedan. Vet inte om att COG var så högt uppe vid testflygningen hjälpte till att framkalla detta.

  20. #20

    Standard

    Det kan vara bra att kalibrera "throttle range" på reglagen.

    Enligt manualen så ser det ut som om man kan slå på broms i de här reglagen precis som på vanliga hobbywing reglage. Det är lätt att kolla genom att vrida på propellern, om den är trögare när batteriet är inkopplat än när batteriet inte är inkopplat så har du bromsen på. I kombination med olyckliga ändlägen på kalibreringen och så skulle det kanske ställa till problem.

    En sak jag tänkte på var om motorerna varvade upp och ner långsamt i kombination med en ram där den mesta vikten sitter i centrum.

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •