Reklam

 
Resultat 1 till 17 av 17

Ämne: Första bygget, motorerna är beter sig konstigt (videoklipp)

  1. #1

    Standard Första bygget, motorerna är beter sig konstigt (videoklipp)

    Hej,

    Börjar bli klar med första quaden men har problem med att få motorerna att spinna som jag vill. När jag trycker på Arm knappen och har throttle längst ner så börjar motorerna spinna ändå, (även fast jag har klickat i "MOTOR_STOP" i cleanflight). När jag sedan ökar throttle så ökar även motorernas varvtal. Men efter ett tag så känns det som att jag har konstant varvtal när jag drar upp och ner på throttle. Vad kan detta bero på?

    00:43 in i videon har jag throttle längst ner och min buzzer piper, varför gör den det?

    https://www.youtube.com/watch?v=9S6N...ature=youtu.be

    Build:
    Acro Naze 32
    X4R mottagare
    Cobra 2204 2300kv (4x)
    Rotorgeeks RG20 plus ESC (4x)

    Tacksam för alla svar och vägledningar jag kan få!

  2. #2

    Standard

    1 har du kalibrerat fartreglagen?
    2 eftersom maskinen inte flyger kommer den inte att reagera korrekt på roder eftersom gyrorna inte känner den förändringen som krävs...
    /Jonas

    Skickat från min Taranis via Tapatalk

  3. #3

    Standard

    Har nu kalibrerat mina fartreglage men kan inte se någon förändring. Klippet nedan visar hur det ser ut i cleanflight när jag ökar throttle på radion.

    https://www.youtube.com/watch?v=o1t2...ature=youtu.be

  4. #4

    Standard

    Som jag skrev, utan propellrar och stående på ett bord fungerar den inte som den ska, den måste flyga.....
    /Jonas

    Skickat från min Taranis via Tapatalk

  5. #5

    Standard

    Jag tycker ändå att motorerna inte bör spinna när jag har throttle längst ner eftersom jag har MOTOR_STOP påslaget. Så vågar inte riktigt sätta på propellrar än och se den börja flippa på golvet :/

  6. #6

    Standard

    Ställ ner värdet Trotel_Min tills motorerna stannar....

    Skickat från min Taranis via Tapatalk

  7. #7

    Standard

    Jag har nu sänkt throttle min så långt ner det går innan motorerna beter sig konstigt (en del spinner och en del inte) men fortfarande inget resultat. Det jag också tycker är märkligt är att motorerna bara börjar spinna när jag har throttle längst ner och inte på något annat ställe när den är armed.

    Klicka på bilden för en större version. 

Namn:	Namnlös.jpg 
Visningar:	40 
Storlek:	61,6 KB 
Id:	58819

  8. #8

    Standard

    Satte på porpellrar och det ger samma resultat som utan. Har throttle längst ner men det är ändå ett otroligt högt varvtal på motorerna. Sänker jag sedan throttle så är varvtalet högre än innan med. Se klippet nedan.

    https://www.youtube.com/watch?v=5Sq-...ature=youtu.be

  9. #9
    Killenheladagens avatar
    Reg.datum
    Sep 2015
    Inlägg
    1 394
    Jobb
    INtT.Licensierad Personlig Tränare
    Klubb
    söker efter klubb el sällskap

    Standard

    Hej!

    Är du medveten om vilket flightmode du är i ? Om du kör cleanflight och ställt in baro- och magnetometerna i det flygläget du är i så kan det förklara saken även om baro-trottel brukar vara ganska "hoppig", beter sig den såhär hela tiden?

    Eller kör du rate? "Motor_stop" påverkar inte när du ger trottel med Cleanflight configurator, den är inte en "throttle hold" -alls utan dikterar om motorerna spinner vid armswitch på och 0 trottel om jag minns rätt.
    Du kan ex sätta airmode och arm på samma switch så när du skall landa switchar du av den (koptern flyger även om du disarmar i luften så länge du har lite trottel på med naze32).


    När du beskriver problemet låter det som den beter sig som den ska förutom den konstanta trottelgivningen. När du skriver att "efter ett tag" så får du konstant trottel oavsett vad du gör? är det då i cleanflight du menar? vad händer om du då vrider ner trottel till 0? och vad händer om du slår på din TX när detta händer.
    Kollat att den inte går in i FAILSAFE? failsafe kan vara inställt på aktiv trottel och försök till att landa autonomt om du har otur...kolla de tabbarna.

    Jag tycker inte du skall på med proppar och flyga maskinen innan du är säker på dessa saker, konstant trottel kan betyda en quad som flyger iväg alt flyger runt i lägenheten och förstör allt den ser.

  10. #10

    Standard

    Jag förstår inte varför man vill att motorerna inte ska spinna när den är armad, det är ju superbra för flygegenskaperna.

    Men vill du inte det så ställer du min trottle på den hastighet dom spinner jämt o fint på när du testar via motor tabben, sen stänger du av arm funktionen ur modes o använder stick arm o disarm då ska det funka. Gör det inte det testa att ställa min command till 960 o se till att radions throttle är kalibrerad 1000 till 2000us.

  11. #11

    Standard

    Jag förstår inte varför man vill använda Cleanflight

    Men om man nu envisas så ^^ Vilket mode man har är ganska väsentligt och jag skulle föreslå rate-mode jämt när man felsöker eftersom där har själva mode:et minst inverkan på hur den beter sig.

    Sen om dina ESC:er är från tidigare än typ augusti 2015 är det möjligt att det är BLheli 13.2 i dom och då fanns det en bugg med OneShot lite beroende på vilken loop-time man använder. Buggen fixades i senare firmware. Om du inte kollat så kolla så det är helt säkert att alla ESC:er har samma firmware och inställningar, ev. disable OneShot och testa.

    Jag förstår inte varför man vill använda BLheli
    Senast redigerat av Glattnos den 2016-07-02 klockan 12:14.

  12. #12

    Standard

    Det ska väll ändå gå att ha en arm-switch och uppfylla kravet att noll throttle inte gör så att motorerna går igång?

    Radion är kalibrerad till 1000-2000us.
    Motorerna börjar rotera vid ca 1050 i cleanflight Så Min throttle är = 1050
    Min command satt till = 960.

    När jag armar quaden och har throttle längst ner går den ändå igång... börjar bli smått galen på detta :/

    Denna videon förklarar hur jag vill ha det, kolla på 19:55

    https://www.youtube.com/watch?v=J3CtoXy53Cw

  13. #13

    Standard

    Spelar ingen roll vilka modes jag kör det blir så gott som samma resultat på alla.

    Köpte dessa fartreglage så tror dom har BLHeli 14.1: http://rotorgeeks.com/index.php?rout...product_id=308

  14. #14

    Standard

    Som jag ser på det så i filmen du visar motor-taben i Cleanflight så der det ju rätt ut. När du armar(antar att det är klicket från switchen man hör) så händer inget. När du gasar så börjar motorerna snurra. När du ger full gas så ökar varvet tills en motor når max. När du minskar gasen så sjunker varvet tills en motor når minimum.

    Att du upplever varvtalet som högt är ju för att FC:n försöker kompensera en rörelse utan att få någon respons eftersom det inte sitter några propellrar på. Den ökar motor 2 och 4 samt minskar 1 och 3 vilket är en pitch_nose_up rörelse, om det är i level mode så är det sannolikt för att quaden stod med nosen lite neråt, om det var i rate mode så är det sannolikt drift eller okalibrerad gyro/accelerometer.

    Så det enda som är fel är ju att motorerna inte stannar när du drar spaken längst ner eftersom motor_stop är aktiverad. Men motor_stop är inte samma som disarm. Jag vet inte hur cleanflight fungerar men den kanske inte stänger av så länge det är för stor diff mellan motorerna, kan va helt fel av mig. Men den stannar väll när du disarmar den?
    I så fall så gå ut och flyg lite med den så ser du om den flyger bra eller om något är jättefel.

  15. #15

    Standard

    Okej det du skriver låter vettigt. Jag är som sagt helt ny på detta och vet egentligen inte vad jag håller på med haha. Jag har Arm på en switch, när jag armar quaden händer inget förns jag har throttle längst ner i mitten, när throttle väl är längst ner så börjar motorerna spinna och detta går inte att stoppa. För att motorerna ska stoppa spinna blir jag tvungen att trycka på disarmswitchen igen. Tror du motorerna slutar spinna om jag avaktiverar motor_stop funktionen?

    Men den verkar gå att flyga om du såg detta klipp: https://www.youtube.com/watch?v=5Sq-6rJfQl8

    I videon jag precis länka så drar jag throttle rakt upp men det verkar inte som att den hovrar på samma ställe, vad kan jag göra för att förbättra balansen?

  16. #16

    Standard

    Hej, jag hade samma problem som dig. Jag är också helt ny på detta. För mig var iallafall problemet att jag hade ett flightmode inprogrammerat i kontrollern fs t6. Tror det var idle up. Så jag behöll det på samma knapp som armering och länkade även kanal 5 (aux1) i cleanflight. Sen ställde jag bara om gränsvärdena i arm inställningen i cleanflight. Sen fungerade det för mig kolla ifall det kan va samma bekymmer för dig. Lycka till!

  17. #17

    Standard

    du har 10 sek delay på motor stop.
    kolla raden under de tabbar som är gröna motor stop osv.
    den delayen är ENDAST aktiverad OM motor stop är aktiverat..
    prova med 0sek,eller ta bort motor stop.

    Klicka på bilden för en större version. 

Namn:	motor stop delay.jpg 
Visningar:	32 
Storlek:	102,6 KB 
Id:	58841

    //Patrik.

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •