Reklam

 
Sidan 2 av 3 FörstaFörsta 123 SistaSista
Resultat 21 till 40 av 42

Ämne: Bra 210-quadram?

  1. #21

    Standard

    Jahapp, nu ska min KISS FC v1.03 programmeras (har 4st KISS 24A ESC 1.08 också), är det bara att ladda ner KISS GUI Standalone 2.0.6 och KISS FCv1 Firmware 1.3 RC34c och tjorva in det?
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  2. #22

    Standard

    Det var ett tag sen jag gjorde detta men, ja, det ska det vara. Jag tror att den gör en registrering/kontroll också första gången man kopplar in den. Om man har KISS ESC också så ska man uppdatera dom också via KISS GUI om dom är inkopplad med alla kablar. Det är lite som ett skydd har jag för mig, om någon av dina komponenter är kopior så kommer programmet tala om det.
    Jag tror att det räcker med att ladda ner GUI så kommer den nog själv leta reda på senaste mjukvara för FC och ESC.

  3. #23

    Standard

    Låter bra det. Den är iaf färdigbyggd nu...

    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  4. #24

    Standard

    Wohoo, vilken liten best
    Är det ett filter du har på sidan där? Behövs det? Sen har du ju den dyraste komponenten på det mest utsatta stället ^^ Annars riktigt snyggt bygge

  5. #25

    Standard

    Haha, ja det borde vara närmare best nu än tidigare. Den förra, en ZMR250, vägde just under 600 gram med samma motorer och 3S 1300. Denna väger 425 gram. Fortfarande 3S, är nog en bra början. Byter jag motorerna kan jag sen köra upp till 6S om jag så vill.

    Filtret, jo jag fick för mig att sätta det på matningen till VTXen. Jag vet inte riktigt hur jag tänkt, för det var egentligen meningen till min SkyWalker X-1. Jag minns inte hur bildkvaliteten var tidigare heller så jag vet inte vad jag ska ursäkta mig med. =)

    Jo jag tänkte på det där med RC-mottagaren... det kändes fel att sätta den där. Men jag vet inte var jag ska ha den och antennerna. Vill nog flytta på den. Den får inte rum "under locket", det är fullt där med PDB + FC + VTX och kamera. :-(

    På tal om dyraste komponenten... jag har ju en GoPro 4 BE som ska vara ovanpå egentligen, så RC-mottagaren kan inte vara där, vete sjutton var de satt den.



    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  6. #26

    Standard

    Jag brukar ta ut mottagaren ur höljet, löda bort pinnarna och löda kablarna direkt på kortet för att sen dra en smidig krympslang över. Det har jag gjort med Futaba R7008SB och R3106GF och det funkar bra
    Antennerna brukat jag ha buntband med krympslang över(som håller antennkabeln). Jag brukar då se till att både buntband och krympslang är tillräckligt långa för att täcka hela antennsladdarna så att dom blir skyddade.

  7. #27

    Standard

    Jag tänkte ha mottagaren till annat också så den fick gärna vara någorlunda flyttbar, men det kan man nog glömma... =) Att ta den ur skalet kunde vara nåt jo, har krympslang som passar. Jag lyckades faktiskt kila in den mellan XT60 och VTX, med skal, ska bara fundera lite till på det eftersom antennerna då tar i propellrarna, det ÄR tajt överallt. Använder bara jord, +5V och signal för SBus-anslutningen. Ska skydda antennändorna med krympslang istället för siliokon-metanolslang. Eller är det dumt att täcka även antennerna? Alltså yttersta änden? Räckvidden ska vara rätt hög med Futaba och jag flyger knappast längre bort än några hundra meter.

    En annan sak jag funderat på är att hitta lillskiten när man kraschat nånstans. Om batteriet är kvar så är det bra om den piper, använda KISS-beep-grejen jag inte har eller ha en vanlig lost signal alarmer? Om batteriet flyger iväg så har jag inte valt en direkt färggrann kombination...
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  8. #28

    Standard

    Nu vart det bättre med RC-mottagaren mellan XT60 och VTX med antennerna framåt och upp i mitten där propellrarna in hugger av dem första uppvarvningen. Sen återstår att se hur mycket alla grejer stör varandra. Ser klart mer clean ut nu. FC-konfiguration härnäst. Man lär ska kunna vända motorriktningen nånstans.

    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  9. #29

    Standard

    Har suttit och klurat på FC-setupen via GUIen.
    Jag tycker det saknas saker och ting och jag får inte mycket att funka.

    1. Hur vänder man motorriktningen, man ska kunna göra det i KISS FC.

    2. När jag går in på fliken "Data output" och lutar quaden fysiskt åt de olika hållen beter den sig inte som väntat (ja FCn är placerad med ovansidan uppåt och pilen pekar framåt som den ska).
    A: Lutar jag quaden fysiskt framåt så lutar den framåt i programmet som den ska, men den samtidigt mjukt långsamt luta mot höger och stannar på samma vinkel åt höger fast jag håller den fysiskt framåtlutande fortfarande. Samt vice versa när jag lutar åt höger, då lutar den sen lutar framåt.
    Och så är det likadant om jag lutar bakåt, då far bakåt och se mjukt över till vänster. Och lutar jag vänster så far den vänster och sen bakåt.

    3. Man kan välja olika PID-presets enlig manualen, välja bland olika quads, det finns inte i min lista, bara Custom och Default samt Zero PIDs. Hur får man in dem? Finns den uppdaterad?

    4. Eller så väljer man User och så får man upp en otrolig mängd med användare som valt sina PIDs. Hur ska jag hitta en QAV-X där? Det är sorterat på användare.

    5. ESC Mode, ska använda OneShot 125 på mina KISS ESC24A?

    6. Hur får man quaden att arma med switch? Jag har ställt in ARM på en switch på sändaren och den rör sig som den ska på den kanalen i GUIen. Men inget händer när jag ARMar.

    7. Hur väljer man flightmodes? Har ställt in en switch för Level, men inget händer.

    Kopplar jag i acken så lyser allt som det ska, gyroskopet kalibrerar sig som det ska, det piper som det ska, men jag kan inte arma eller göra nåt.
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  10. #30

    Standard

    Nu ska vi se hur mycket jag minns, sitter utomlands utan datorn så det blir bara vad jag kommer ihåg.

    1. Som jag skrev förut så är det en lödbrygga på ESCarna som bestämmer rotationsriktningen, det är därför man inte ska värma krympslangen innan man testat och bryggat de ESCer som ska vändas. Jag tror inte att man kan vända riktning i GUI, men jag är inte säker då jag aldrig tänkt på det. Att det går i många andra FC GUI som Betaflight mm är egentligen för att ESC mjukvara som BLheli mm har den funktionen och jag tror att KISS valt att hårdvarubasera det med en lödbrygga istället i sin ESC mjukvara.

    2. Det låter som att accellerometrarna driftar på nått vis, det händer ju ibland om nått sitter nära sensorn som antingen blir varmt eller ger magnetisk störning. Jag tror att den kalibrerar varje gång man kopplar in batteriet så den ska stå så rakt som möjligt när det kopplas in och sen stå stilla ett par sekunder. Eftersom jag i princip aldrig kör level mode så är jag inte så insatt i kalibrering och hur accelerometrarna jobbar. Jag kopplar in batteriet och ställer direkt quaden på marken, sen är det bara att flyga.

    3 och 4. Default PID bör funka att börja med. Jag tror att jag kört på en setting från User FinalglideAUS. Jag tror inte att det är så himla noga vad man börjar med, den kommer flyga på Default PID. Jag har för mig att antingen MrSteele eller FinalglideAUS berättar i en Youtube-film när han byggde ny quad en dag innan en stor tävlingen(kanske Dubai eller Hawai) för nått år sen. Han hade bara testat quaden på hotellrummet kvällen innan tävlingen. Många frågade hur han lyckades justera sina PID för att kunna tävla och han sa bara att så länge man inte ska göra riktigt crazy freestyle så spelar det ingen roll utan han tävlade helt enkelt på Default PID.

    5. Kör inte OneShot utan Dshot t.ex. Dshot600.

    6. Jag armar på en switch och jag har för mig att det bara är att välja en switch för arm och sen se till att den står i unarmed läge samt att throtteln är på lägsta när man kopplar in batteriet. Det kan ju ha att göra med Level-mode om det driftar av någon anledning, prova att inte ha något levelmode och se om den armar i vanligt rate-mode.

    7. Det bör ju bara vara att välja levelmode på en switch. Jag tror att jag gjort det nån gång för att testa och konstaterat att det gör det.

  11. #31

    Standard

    Stort tack för svaret ditt!!

    1. Oj, jag hade missat lödbryggan. Jag hade sett denna film https://www.youtube.com/watch?v=9SuuGXwnaoM

    2. Det skumma är att det är exakt 90 grader fel på slutet. De stannar stabilt. Har haft quaden stå stabilt på bordet och inte rört något under uppstarten (5 sek blink och lyser sen slocknar). Jag vill också bara koppla i acken och flyga. =) Så gjorde jag med Naze32an förut. Måste få det inställt först bara.

    3. 4. Defualt it is!

    5. Ok, byter till Dshot600 om det finns. Den borde väl ha ställt om själv till OneShot efter att jag flashat KISS 24A ESCarna enligt GUIens förslag.

    6. Det med ARM, har valt switch och vilket håll den ska vara åt, men den armar aldrig. Får klura lite till där.

    7. Samma som 6. Rätt inställ, inget händer, får testa lite mer.

    Det som oroar mest är punkt 2.
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  12. #32

    Standard

    Det med lutningen. Förstår jag dig rätt att den yawar åt höger när du lutar den? Gör den det långsamt?
    Om den reagerar rätt på snabba rörelser så är ju FC orienteringen rätt. Om den vrider sig fel lite långsammare över tid så kan det vara inputsignalerna som inte är tillräckligt centertrimmade eller så är kanske deadband satt lite för lågt(sätt det jättehögt och se om det funkar då). För du har väl radion påslagen när du testar?
    Annars är det ju nått med accelerometrarna, kalibrering som inte blir rätt eller så störs dom på nått vis. Jag hade ett liknande problem med en Naze32 en gång, jag fick aldrig till den men den funkade bra i rate-mode så det var nog helt enkelt fel på accelerometrarna i den.

  13. #33

    Standard

    Lutningen...

    Nix, den yawar inte alls. Lutar.

    Den reagerar snabbt på alla rörelse precis som den ska, men, se nedan...

    Radion är på japp.

    Quaden står still och stabilt på bordet och i "Data output".
    Jag har ingen koll på vad som är fram och bak för det är inte märkt på denna live-3D-bild, vilket är helkorkat. En pil hade varit klokt.
    När jag lutar quaden framåt fysiskt (med främre bommarna på bordet och bakre lyfts upp från bordet) så gör den det på bilden också, men den börjar sakteliga luta åt höger och sen stannar den där med exakt samma lutning, men som sagt åt höger. Den roterar inte, den bara lutar. Så det slutar alltså med att quaden fysiskt lutar framåt på bordet men på bilden så lutar den åt höger.

    Jag tycker det är så skumt att den hamnar i rätt vinkel men åt ett annat håll.

    Kalibreringen... då ligger den platt på bordet och jag klickar på Calibrate level eller va det stod. Det händer inget, men quaden blir plan i bilden i GUI.

    Med tanke på hur otroligt kompakt de är tänkta att byggas så tycker jag störningar borde vara genomtänkt bortplockat på något vis. Kan även prova att plocka isär quaden och sära på allt.
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  14. #34

    Standard

    Du kan fortfarande inte arma den eller? Har du ställt in så att throttel-kanalen(och de övriga) går mellan 1000-2000? Om inte throtteln är på 1000 har jag för mig att den inte armar.
    Du har kanske redan koll på det men ”arm on switch” betyder inte att propellrarna börjar snurra när man armar, så att om inget verkar hända när man armar behöver inte vara fel. Det beror lite på hur ”min-throttle” är inställd.

    Om den armar så skulle jag testat att flyga den och se om nått verkar konstigt för att kunna utesluta att det är GUI eller drivrutiner på datorn som krånglar.

  15. #35

    Standard

    Fick ett ryck igår... problemen löstes en efter ett... =)

    Jag satte deadband från 0 till 100 (av 250 max), men det gjorde ingen skillnad med nåt.

    Resettade allt...

    I den vyn där man ser rates osv och en 3D-simulering av quaden så låg den och roterade och vred sig i alla led. Såg att samtliga mittlägen var på ca 1515 så jag subtrimmade ner dem (roll, tilt och yaw) till 1500 och då var allt rock solid.

    Arm-problemet... satte ARM på Low och ställde in switchen på 1000-2000. Men när jag slog switchen på low enligt mig, så vart den inte 1000, utan 2000. Reverserade i radion... Doh! Men den armade ändå inte.

    (samtidigt satte jag Level till Low och reverserade så Low = 1000 där också, och inte 2000 som jag hade först... doh igen, man borde fatta att 1000 är low och inte 2000)

    Sen såg jag i den vyn där man ser RC-utslagen, att throttle inte alls var 1000 utan 1100-nånting. ?! Det var den inte före reset, nåja, jag trimmade på sändaren ner detta så det blev 1000. Hade nog gjort det före reset också, men om man inte har koll på Low och High vs 1000 och 2000 så blir det ändå inte rätt, fast jag flippade switcharna i alla lägen. Men, men, missade säkert att ha allt i rätt läge när jag anslöt acken.

    Nu armar lillskiten och allt beter sig som det ska... nästan.

    I "data output"-fliken lutar den fortfarande åt fel håll långsamt. Dvs lutar jag quaden fysiskt framåt 45 grader så lutar den sig sen sakta mak mot höger 45 grader och stannar där. Samt tvärtom. Och lutar jag bakåt så lutar den sig sen sakta mak till vänster och håller sig där med 45 graders lutning. I dont fatt.

    Sen det där med switch för Level. Jag har inte kruxat i 3D. Så när jag slår om switchen för Level till Low (1000) så blir det Level. Men vad det är annars, det vet jag inte. ?! Man kan välja Low och Low+Medium. Antar att det är om man använder en trelägesswitch.

    Jag vet inte hur andra fått upp inställningar i sina KISS GUI för att ändra rotationsriktningen på valbara motorer. Kanske en feature som fanns på tidigare versioner av GUI, jag har nu den senaste, hur man nu ska gilla det. Så jag måste löda fast den där rotation-lödbryggan. Går lätt att skära upp ett hål med skalpell i den genomskinliga krympslangen och tejpa över.

    Videolänken har finfin bild.

    Så jag siktar på testflygning idag. Tack för hjälpen Sniff!! =)
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  16. #36

    Standard

    Va bra att vissa saker löser sig Men det där med lutningen är ju helskumt.

  17. #37

    Standard

    Allt funkade som det skulle igår, men den där lutningen är kvar i luften. Flyger jag framåt så lutar det mer och mer till höger. Man måste efter ett tag tvinga in den i nån annan riktning så man blir av med lutandet åt fel håll, speciellt eftersom det blåste en del igår, blev att komma nära skogen några ggr. =) Vet inte vad jag ska göra åt det... inte kul flyga när den är så. Men annars så beter sig resten som det ska.
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  18. #38

    Standard

    Det låter precis som felet jag hade med min Naze32 förut. Det gick aldrig att få till så jag antar att det helt enkelt är en trasig accelerometer. Hör av dig till butiken du köpte FC:n av och be att få reklamera den eftersom den verkar felaktig. Då får antingen butiken eller tillverkaren bevisa att den funkar men jag tror det är sensorn som är trasig.

    Innan du skickar tillbaka den så kan du koppla in den i datorn när FC:n är urplockad ut quaden och "ren" från övriga prylar. Om den gör likadant då när du håller den i handen så är den ganska säkert felaktig.

  19. #39

    Standard

    Jag kopplade upp igen...

    Så här ser det ut från början:



    Till vänster (där nere) ser man gyroscope- och accelerometer-värdena.
    Det som jag undrar över är varför accelerometer Z är högre upp än de andra (mörkgröna linjen), den står på 1, de andra på 0.

    För att testa:

    1. Förändring genom att rotera åt något håll:
    Roterar jag runt roll-axeln (X-axeln) så ökar/minskar Gyroscope X beroende på vilket håll jag roterar.
    Roterar jag runt pitch-axeln (Y-axeln) så ökar/minskar Gyroscope Y beroende på vilket håll jag roterar.
    Roterar jag runt yaw-axeln (Z-axeln) så ökar/minskar Gyroscope Z beroende på vilket jag håll jag roterar.
    De verkar bete sig som det ska, de känner av förändringen medans den görs, stannar jag upp så faller värdet tillbaks till 0.

    2. Förflyttning som mäts av accelerometrarna:
    Rör jag quaden åt höger/vänster så ändrar Accelerometer X efter det men far tillbaks.
    Rör jag quaden åt fram/bak så ändrar Accelerometer Y efter det men far tillbaks.
    Rör jag quaden åt uppåt/neråt så ändrar Accelerometer Z efter det men far tillbaks.
    Helt OK! Så ska det ju vara.

    Det känns som att hårdvaran funkar, men inte mjukvaran. Eller hur?

    Sen till den delen där det skumma börjar hända...

    3. Gyrot känner av vart det lutar.
    Om jag lutar quaden 90 grader till höger runt X-axeln så ökar Accelerometer X från 0 till +1 (-1 om jag lutar 90 grader till vänster). Helt OK!
    Om jag lutar quaden 90 grader framåt runt Y-axeln så ökar Accelerometer Y till +1 (-1 och jag lutar 90 grader bakåt). Helt OK!
    Sen kommer vi till det jag inte fattar... Accelerometer Z (den är inte 0, den är +1!!!). Jag skulle tycka att om jag roterar quaden 90 grader medurs runt Z-axeln så ska Accelerometer Z öka från 0 till +1. Men det gör den inte, den är +1 redan.

    Och det skumma nr 2...
    När jag lutar 90 grader åt höger, vänster, framåt eller bakåt så minskar Accelerometer Z från 1 till 0.
    Lutar jag ytterligare 90 grader så minskar Accelerometer Z från 0 till -1.
    Dvs Accelerometer Z = 1 när quaden är rätt väg och -1 när den är upp och ner.

    Och det skumma nr 3...
    När jag rör på quaden runt de olika axlarna och hit och dit så ändrar värdena vartefter. Och när jag slutar röra den så stannar värdena upp. Men i 3D-bilden fortsätter quaden rotera till sin felaktiga position. Utan att värdena i grafen ändrar. Detta tar ca 6 sekunder. Varför ändrar det inte direkt? Varför kryper det?

    Ser man på värdena under Other... där finns AngleX och AngleY.
    De är på 0 när quaden ligger plant.
    Lutar jag till höger runt X-axeln så blir AngleX = +90 grader. Helt OK! (men AngleY ändrar sakta från 0 till -180)
    Lutar jag till vänster runt X-axeln så blir AngleX = -90 grader. Helt OK! (men AngleY ändrar sakta från 0 till +180)
    Lutar jag framåt runt Y-axeln så blir AngleY = +90 grader. Helt OK! (men AngleX ändrar sakta från 0 till -180)
    Lutar jag bakåt runt Y-axeln så blir AngleY = -90 grader. Helt OK! (men AngleX ändrar sakta från 0 till +180)

    Huuur kör man in ny firmware? Finns ingen knapp för det i denna GUI för att ställa in KISS FC. Men i denna GUI kan man uppgradera ESCarnas Firmware. Jag kör nu KISS FC 1.2 men har 1.3 nedladdad.
    www.rcaland.ax --- Im an Aalandish Djaekenfaelt'er! =)

  20. #40

    Standard

    Mycket bra beskrivning!
    Det skumma nr 1 och 2 är som det ska. En accelerometer mäter G-krafter, Z är vertikalt och när den står plant så är det 1 G vertikalt neråt pga jordens gravitation.
    Det skumma nr 3 är lite mystiskt. Jag antar att du har ställt den plant och klickat på "Calibrate acceleerometers" vilket borde ge den en uppdaterad vertikal-position. Eftersom du flugit den och får samma problem med lutningen då så är det ju nått som inte stämmer.
    På bilden har du Acro-mode(samma som rate-mode), vad händer om du slår om switchen till "level-mode"? Blir det någon skillnad på hur GUI:t beter sig då?

    Uppdatera FCn gör man enligt denna guide: https://www.youtube.com/watch?v=D8FLhC3gs5w
    Dock ska den ju funka med den mjukvaran som är på men det kan ju vara värt att testa att uppgradera den.

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •