Reklam

 
Sidan 2 av 3 FörstaFörsta 123 SistaSista
Resultat 21 till 40 av 50

Ämne: Uppgradering av FrSky X8R

  1. #21

    Standard

    Citat Ursprungligen postat av Göran R Visa inlägg
    Den externa modulen skall väl vara på och inställd på PPM för att ge spänning till mottagaren (enligt painless-videon).
    Nej, radion spännings sätter den pinnen när du kör flash, har du PPM aktivt finns risken att den inte kan göra reset.
    /Jonas

    Skickat från min Armor X8 via Tapatalk

  2. #22

    Standard

    Citat Ursprungligen postat av Göran R Visa inlägg
    Vad jag inte förstår är varför jag har denna bilden under Model setup menyn.
    Bifogad fil 72756


    Vid Module status skall väl det visas vilken firmware man kör på dvs V1.3.2.61 AETR

    Jag får samma text oavsett vilket flygplan jag tittar på. Vart tog multi Module Firmware infon vägen ????
    Kan vi gissa att du försökte köra flash firmware för en mottagare med din externa modul i radion?
    Tror modulen blir ganska missnöjd med en firmware för en mottagare i sig.....
    /Jonas

    Skickat från min Armor X8 via Tapatalk

  3. #23

    Standard

    Citat Ursprungligen postat av thoabr Visa inlägg
    Hej

    Har inte radion 3 stift uttag särskilt för update. Har q7 x10 iallafall. Inte i modulfacket.

    Thomas
    Det är nog bara Q7 och möjligen någon Horus som har separat kontakt....
    /Jonas

    Skickat från min Armor X8 via Tapatalk

  4. #24

    Standard

    Citat Ursprungligen postat av FinnbyFraggel Visa inlägg
    Nej, radion spännings sätter den pinnen när du kör flash, har du PPM aktivt finns risken att den inte kan göra reset.
    /Jonas

    Skickat från min Armor X8 via Tapatalk
    Jag provade med OFF i båda modulerna. Ingen skillnad. Har också provat att nedgradera och uppgradera multimodulen men får bild med error i sändardisplayen. Jag tror det är fel i multimodulen enligt bilden som jag skickade ovan. Det blir kontakt med Radiomasters service nu.

  5. #25

    Standard

    Citat Ursprungligen postat av Göran R Visa inlägg
    Jag provade med OFF i båda modulerna. Ingen skillnad. Har också provat att nedgradera och uppgradera multimodulen men får bild med error i sändardisplayen. Jag tror det är fel i multimodulen enligt bilden som jag skickade ovan. Det blir kontakt med Radiomasters service nu.
    Skulle gissa att du råkat få in en X8R firmware i din externa multiprotokoll modul.
    Du får hälla ner rätt firmware i modulen via USB / TTL RS232.
    Varför du inte lyckas byta firmware i mottagaren kan jag tyvärr inte gissa med den infon jag har...
    Möjligen att du använder fel firmware fil, Frsky har det gjort väldigt besvärligt för sina kunder att hitta rätt i deras firmware djungel för att försöka eliminera 3-parts tillverkare av mottagare och det enda dom lyckades åstadkomma var att skjuta sig själva i foten.....

    /Jonas

    Skickat från min Armor X8 via Tapatalk

  6. #26
    thoabrs avatar
    Reg.datum
    nov 2006
    Inlägg
    193
    Jobb
    pensionär
    Klubb
    Marks mfk

    Standard

    Har du laddat in updateringen i firmware på sd kortet.

    På under sidan av radion finns ett utag 4 pinnar. Längst ut finns rx höger(mottagare) Till vänster jord sen plus. Finns en text där.

  7. #27
    thoabrs avatar
    Reg.datum
    nov 2006
    Inlägg
    193
    Jobb
    pensionär
    Klubb
    Marks mfk

    Standard

    Dom är för updatering

  8. #28
    uffe_46s avatar
    Reg.datum
    jul 2015
    Inlägg
    682
    Jobb
    Systemingenjör
    Klubb
    Sala Radioflygklubb Mosquitos

    Standard

    Citat Ursprungligen postat av thoabr Visa inlägg
    Dom är för updatering
    Det här har jag väldigt svårt att förstå, har du någon dokumentation på detta gärna en länk till den.
    Enligt den information som jag har hittat är detta Uart portar som kommunicerar där TX sänder och RX tar emot, så att använda RX porten är väldigt konstigt. Pinnen i modul facket är däremot dubbel riktad både sänder och tar emot

  9. #29
    thoabrs avatar
    Reg.datum
    nov 2006
    Inlägg
    193
    Jobb
    pensionär
    Klubb
    Marks mfk

    Standard

    Står i manualen att den är för updatering.

  10. #30
    uffe_46s avatar
    Reg.datum
    jul 2015
    Inlägg
    682
    Jobb
    Systemingenjör
    Klubb
    Sala Radioflygklubb Mosquitos

    Standard

    Citat Ursprungligen postat av thoabr Visa inlägg
    Står i manualen att den är för updatering.
    Ja jag har sett att det står så i manualen, för kompatibla mottagare, vad det nu är för något. Alla de tunga namnen på YouTube använder porten i modulen, för uppdatering av mottager, kan inte hitta något på nätet om att de där portarna i botten kan användas till något vettigt .... än, det kanske kommer i kommande uppdateringar av OpenTX, precis som stöd för touch skärm.
    Så om vi håller oss till fakta här så underlättar vi för många

  11. #31
    uffe_46s avatar
    Reg.datum
    jul 2015
    Inlägg
    682
    Jobb
    Systemingenjör
    Klubb
    Sala Radioflygklubb Mosquitos

    Standard

    Citat Ursprungligen postat av Göran R Visa inlägg
    Jag provade med OFF i båda modulerna. Ingen skillnad. Har också provat att nedgradera och uppgradera multimodulen men får bild med error i sändardisplayen. Jag tror det är fel i multimodulen enligt bilden som jag skickade ovan. Det blir kontakt med Radiomasters service nu.
    Skriv gärna här hur det gick med din kontakt med Radiomaster support

  12. #32

    Standard

    Citat Ursprungligen postat av uffe_46 Visa inlägg
    Skriv gärna här hur det gick med din kontakt med Radiomaster support
    Jag skrev till dem igår och jag återkommer om detta. /Göran

  13. #33

    Standard

    Citat Ursprungligen postat av FinnbyFraggel Visa inlägg
    Skulle gissa att du råkat få in en X8R firmware i din externa multiprotokoll modul.
    Du får hälla ner rätt firmware i modulen via USB / TTL RS232.
    Varför du inte lyckas byta firmware i mottagaren kan jag tyvärr inte gissa med den infon jag har...
    Möjligen att du använder fel firmware fil, Frsky har det gjort väldigt besvärligt för sina kunder att hitta rätt i deras firmware djungel för att försöka eliminera 3-parts tillverkare av mottagare och det enda dom lyckades åstadkomma var att skjuta sig själva i foten.....

    /Jonas

    Skickat från min Armor X8 via Tapatalk
    Jag tror att du är lite på spåret. På error bilden, som jag får upp efter det att jag försökt ladda ner firmware igen, så står det "no sync". Letat på nätet och enligt de anvisningar som jag hittade, så är bootloadern till multimodulen skadad och måste uppgraderas igen. Det är väl det du menar med att hälla i ny firmware via USB / TTL RS232? Det kräver väl lite mer utrustning/interface, som jag inte har och jag vet inte heller hur man gör, så jag väntar först på att Radiomasters servicekille skall kontakta mig. Det kan ju vara ett hårdvarufel också. Fortsättning följer.
    /Göran

  14. #34

    Standard

    Citat Ursprungligen postat av Göran R Visa inlägg
    Jag tror att du är lite på spåret. På error bilden, som jag får upp efter det att jag försökt ladda ner firmware igen, så står det "no sync". Letat på nätet och enligt de anvisningar som jag hittade, så är bootloadern till multimodulen skadad och måste uppgraderas igen. Det är väl det du menar med att hälla i ny firmware via USB / TTL RS232? Det kräver väl lite mer utrustning/interface, som jag inte har och jag vet inte heller hur man gör, så jag väntar först på att Radiomasters servicekille skall kontakta mig. Det kan ju vara ett hårdvarufel också. Fortsättning följer.
    /Göran
    Beroende på vilken 4in1 modul du har så kan det finnas en USB kontakt på modulen, om inte får man använda en extern USB -> RS232TTL för att prata med modulen och använda "Flash multi" för att få in korrekt firmware och bootloader eftersom den inte kan prata med radion.
    Jag skulle bli mycket förvånad om du får hjälp av Radiomaster då det är du själv som skrivit fel firmware till modulen i radion....
    /Jonas

    Skickat från min Armor X8 via Tapatalk

  15. #35

    Standard

    Jag tror inte jag skrivit någon firmware till multimodulen. Problemen började när jag skulle programmera X8R. Jag följde videoanvisningarna (De som hänvisats till tidigare). Skiftade +/-, anslöt till de tre nedersta pinnarna i bakre facket och skickade till external med inställt ppm. Avstängd internal RF. Men något gick fel vad det nu var. Därefter såg Module status ut som bilden. Angående USB kontakt på interna modulen, var skulle denna kunna vara? Kolla bilden.
    Klicka på bilden för en större version. 

Namn:	IMG_0867.jpg 
Visningar:	24 
Storlek:	103,4 KB 
Id:	72780Klicka på bilden för en större version. 

Namn:	Multimodulfel_bild.jpg 
Visningar:	27 
Storlek:	112,9 KB 
Id:	72779

  16. #36

    Standard

    Okej, du måste löda dit kontakt stift eller kabel och ansluta till USB serial TTL adapter och byta firmware den vägen.
    /Jonas

    Skickat från min Armor X8 via Tapatalk

  17. #37

    Standard

    Tack för hjälpen,
    /Göran

  18. #38
    uffe_46s avatar
    Reg.datum
    jul 2015
    Inlägg
    682
    Jobb
    Systemingenjör
    Klubb
    Sala Radioflygklubb Mosquitos

    Standard

    Citat Ursprungligen postat av Göran R Visa inlägg
    Jag tror att du är lite på spåret. På error bilden, som jag får upp efter det att jag försökt ladda ner firmware igen, så står det "no sync". Letat på nätet och enligt de anvisningar som jag hittade, så är bootloadern till multimodulen skadad och måste uppgraderas igen. Det är väl det du menar med att hälla i ny firmware via USB / TTL RS232? Det kräver väl lite mer utrustning/interface, som jag inte har och jag vet inte heller hur man gör, så jag väntar först på att Radiomasters servicekille skall kontakta mig. Det kan ju vara ett hårdvarufel också. Fortsättning följer.
    /Göran
    Tro att jag har en en TTL RS232 liggande här någon stans, du kan få låna den om du vill

  19. #39

    Standard

    Citat Ursprungligen postat av uffe_46 Visa inlägg
    Tro att jag har en en TTL RS232 liggande här någon stans, du kan få låna den om du vill
    Tack för erbjudandet Uffe. Jag avvaktar Radiomasters svar. Vill inte göra lödningar om jag skall skicka radion till RM. Men det kanske är bra att ha en egen på sikt om man snubblar på tangenterna i framtiden. Vad kan en lämplig sådan ha för artikelnummer/spec om jag vill köpa, en som passar, på nätet?

  20. #40

    Standard

    Citat Ursprungligen postat av Göran R Visa inlägg
    Tack för erbjudandet Uffe. Jag avvaktar Radiomasters svar. Vill inte göra lödningar om jag skall skicka radion till RM. Men det kanske är bra att ha en egen på sikt om man snubblar på tangenterna i framtiden. Vad kan en lämplig sådan ha för artikelnummer/spec om jag vill köpa, en som passar, på nätet?
    Den här fungerar bra då den har 3.3V och 5V omkopplare.
    https://www.kjell.com/se/produkter/e...arduino-p88064
    /Jonas

    Skickat från min Armor X8 via Tapatalk

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •